M3K: How to check active and resolved alarms on M1K via CLI? - acDChannelStatus


Doc ID    SOLN276648
Version:    4.0
Status:    Published
Published date:    13 Oct 2017
Created Date:    12 Oct 2015
Author:   
Levente Szabo
 

Details

Mediant 1000

Problem Clarification

12/2:47,ACT|##acDChannelStatus##,36,D-Channel Alarm. D-Channel is Out Of Service,Interface#0/trunk#3,4,161,1,12,,,,MAJ

Cause

possibly PSTN related problem

Solution

As the alarm shows there is a D-channel that is out of service therefore we would need to check whether the alarm is indeed still active or cleared.

Note in the alarm description how the interface and trunk numbers are displayed -highlighted in yellow- and also note the number highlighted in red: 161. This is the alarm ID

Interface#0/trunk#3,4,161,1,12,,,,MAJ

Also note the date/time reference in the alarm description:

12/2:47  <<<< This means the alarm was reported on the 12th of the current month.  (Note how the month/year is not included, only the day.) The 2:47 is the time which does NOT match the actual system time zone configured on the M1K. Avaya alarming expert tool uses its own configured time zone settings when it logs a ticket for a system generated alarm, hence the time offset.

Now log into the CLI of the M1K via SSH and issue these commands:

show system active-alarms   <<<< This will provide the list of currently active alarms on the system. If the outputs says "active alarm table is empty" it means no current active alarm were found on the system at all and all is OK.
 

Now to check the alarm history:

show system alarms-history  <<< This will provide the list of historical alarms where the "Seq" column contains the alarm IDs. Based on the alarm ID one can check on the alarm reported in the alarm description and when it got resolved.

Here is a sample output showing when eg alarm ID 161 got logged as active and a bit later on alarm ID 164 indicates that alarm ID 161 cleared:

 

Mediant 1000> sh sys alarms-history
Seq. Source                         Severity   Date                   Description
---------------------------------------------------------------------------------
<...>

161. Interface#0/trunk#3            major      12.10.2015 , 8:47:12   D-Channel Alarm. D-Channel is Out Of Service
162. Interface#0/trunk#2            major      12.10.2015 , 8:47:15   D-Channel Alarm. D-Channel is Out Of Service
163. Interface#0/trunk#2            cleared    12.10.2015 , 8:47:24   Alarm cleared: D-Channel Alarm. D-Channel is Out Of Service
164. Interface#0/trunk#3            cleared    12.10.2015 , 8:47:27   Alarm cleared: D-Channel Alarm. D-Channel is Out Of Service


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