AMM Users unable to login at GUI


Doc ID    SOLN277996
Version:    4.0
Status:    Published
Published date:    25 Jan 2019
Created Date:    03 Nov 2015
Author:   
taf1
 

Details

When standard user or administration account on 2012 AD, try's to login to the GUI (AMM FQDN/8445/admin) They get unauthorized account or Internal server error, more details in the OAMP log. this is for LDAP users or LDAP administrator set up when configuring the AMM.

From the OAMP log:

<11>Jun  9 11:26:29 copdamm.service.ca SSO[10223]: -04:00 2016 263 1 com.avaya.aem.oamp | 0 (SsoClientAuthenticator.java:213) Error authenticating user AMMservice: javax.security.auth.login.FailedLoginException: Password Incorrect/Password Required

Problem Clarification

System was just installed and moved from a 2003 AD for LDAP, to a 2012 R2 Active Directory, and reprogrammed at that time.

Cause

All details were provided by the customer and the NOC team for the Active Directory, details are important and spelling is critical.

Solution

 Since you can’t access admin GUI you can do it by using utility: /opt/Avaya/MultimediaMessaging/2.1.0.0.833/CAS/2.1.0.0.833/bin/configureAMM.sh .

Then go to LDAP configuration and check configuration. Can you try to input credential again and reapply the settings. Then restart AMM (or it will be done by utility) and check if the issue is resolved.
 Check spelling and make sure letters are capital when needed and nothing is missed.


In the JBoss logs we could see the system checking the roles and names and permissions, these should match what was programmed in the LDAP configuration utility. To collect the JBoss log

You can find it at /opt/Avaya/MultimediaMessaging/2.1.0.0.833/jboss-as/7.1.1/standalone/log

Additional Relevant Phrases

New install of AMM, getting Unknown Error and Invalid username or Password, when trying to login to the URL AMM FQDN:8445/admin upgrade to 3.0 AMM https://<serverFQDN>:8443/aem/resources returns a 500 error. Need to check the administration and programming of the AD accounts

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