Called and calling party display numbers differ on direct Agent calls when call routed via DCS trunk than when routed via ISDN QSIG trunk.


Doc ID    SOLN278158
Version:    2.0
Status:    Published
Published date:    28 Aug 2016
Created Date:    05 Nov 2015
Author:   
Guest User
 

Details

 

 

 

CM1: R015x.01.2.416.4
patch: 01.2.416.4-17871

CM2: R015x.01.2.416.4
patch: 01.2.416.4-16770

Problem Clarification

Using ISDN H323 trunks to link 2 CMs. The calling agent ID displays on
called phone, but the station number of the called party shows on the calling phone.
Customer wants the agent IDs of both calling and called party to display on phones.

Cause

This is how QSIG works and we cannot compare it to DCS which was old and proprietary way of Avaya doing private networking. There are many features which DCS couldn’t do and QSIG can do as it is industry standard.

 

Labor Test: CMA---QSIG---CMB

 

Agent A logged in on station 6011 in CMA

Agent B is logged in on station 5002 in CMB

 

Call Scenario:

Agent B login id: 4222 and is logged into acd skill in CMB

Agent A login id: 6066 and is logged into acd skill in CM A

 

Agent A initiates a call to agent B by dialing agent id 4222 and call goes over qsig trunk.

while the call is ringing  Agent A see Agent B name on its display

while the call is ringing Agent B see : Agent A to Agent B on its display

 

when Agent B answers the call, the display on Agent A changes to the station name of agent B

 

The above test scenario matches customer's scenario and the same behavior was observed.

 

This is working as design because an Agent ID call is like a call forward call to the physical station therefore when agent B answers then the connect message has a connected name and number which will be those of the physical station and that’s why caller Agent can see the display changing from agent name/number to station name/number.

 

Solution

Working as designed.

Avaya development confirmed this is working as designed, via ISDN QSIG trunk the display is updated. Behavior differs on QSIG trunks from old Avaya proprietary DCS trunks.

Additional Relevant Phrases

Agent phone always display connected station number whenever call is made from Agent to another Agent over IP/SIP trunk.

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