Secure Access Link: Remote access problem after installing Service Pack 2 on SAL 2.5


Doc ID    SOLN278436
Version:    5.0
Status:    Published
Published date:    14 Sep 2016
Created Date:    10 Nov 2015
Author:   
Lauren Mitchell
 

Details

SAL 2.5 (bundled with ADS 2.5).

Problem Clarification

Remote access is no longer working after installing Service Pack 2 on the SAL gateway.

Cause

When you do an upgrade on SAL 2.5 to SP2, if the certificate name is entered differently than what's in the GWUI (uppercase letters instead of lowercase, for example), it will need to be changed ahead of time otherwise you will be locked out.

If the upgrade is completed but it is discovered that Avaya and/ or the BP are locked out, immediately look in the xGate.log for a certificate error (referring to the CN being different than what is on the server). Example;

[ 0,  9,  7, 227] 11-10-2015 09:23:54.936 ERROR-- xgEnterpriseProxy: Web Client (https://SAL_BP_NAME.BP_SITE.com/eMessage): SSL: server's certificate verification failed (error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed)

 

note: before you apply service pack please install 2.5 installer then apply the service pack

Solution

Update the "Remote Server" information in the SAL user interface to match the name of the Business Partner certificate exactly.

Additional Relevant Phrases

Avaya cannot access SAL after adding Service Pack 2 Unable to establish SSH connection to SALGW from BP remote concentrator however the SALGW is sending alarms and heartbeats properly and accessible from Avaya. The request from BP concentrator sits on "waiting for remote host...". Upgrade from 2,2 to 2.5 browser related issues - firefox 36 works others dont

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