SAL Gateway: SpiritAgent Fails To Start/Restart


Doc ID    SOLN278936
Version:    4.0
Status:    Published
Published date:    02 Mar 2021
Created Date:    18 Nov 2015
Author:   
Mark Hunter
 

Details

SAL Gateway versions 2.3 and 2.5

Problem Clarification

The spiritAgent service fails to start or restart, producing errors similar to the following:

Message from syslogd@ at XX ...LRSALGW01 SPIRIT: XX LRSALGW01 SPIRITAgent[noProcessID]: -06:00 2015 224 1 com.avaya.spirit.util.logging.SPIRITCommonLogger | 1 com.avaya.spirit.agent.logging O_AG-AG0017 O_AG-AG0017 SPIRIT Agent Start FAILED: java.lang.NullPointerException

SAL Agent is also not running in the SAL Gateway user interface.

Cause

Failed auto-upgrade from the SAL Gateway. When the upgrade took place it did not build any files under:

/opt/avaya/ads/logging

 

Solution

Create an empty text file in the /opt/avaya/ads/logging directory and give it 644 permissions (rw-r--r--) and then restart the SAL services.

To change permissions use:

chmod 644 filename.txt

To restart the SAL services:

service salWatchdog restart

service spiritAgent restart

service gatewayUI restart

The spiritAgent service should now start successfully and the SAL Agent should now be running in the SAL Gateway user interface.

Additional Relevant Phrases

SpiritAgent unable To Start/Restart. SpiritAgent not ableStart/Restart. SpiritAgent cannot Start/Restart. SpiritAgent do not Start/Restart. SAL gateway not recognizing spirit agent service. unhealthy remote access observed in SAL

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