CM: Internal dialing getting wave off / calltype XXXX#, no match


Doc ID    SOLN279275
Version:    5.0
Status:    Published
Published date:    31 Jul 2017
Created Date:    20 Nov 2015
Author:   
David Polley
 

Details

One of my DID numbers is being rejected by the PBX, or so says the provider
customer getting no call type denial in list trace

Problem Clarification

customer unable to dial a 4 digit extension with the 11 digit number IE:1XXX-XXX-2799
also i was unable to calll it remotely wave off /fast busy

Cause

Able to find this denial in list trace

 

11:17:14 TRACE STARTED 11/19/2015 CM Release String cold-03.0.124.0-
11:17:34     Calling party trunk-group 2 member 12    cid 0x24a7
11:17:34     Calling Number & Name
11:17:34     active trunk-group 2 member 12    cid 0x24a7
11:17:34     calltype 2799#, no match
11:17:34     idle trunk-group 2      cid 0x24a7

 

this is caused by incorrect programming in Call type Analysis table

A similar issue would look like this but an entry may be missing from the aar analysis table. In this case it would look like this:

08:25:44     calltype 8880# match=8  
08:25:44     calltype 1008880#, no match 
08:25:44     calltype 1008880, no match

In this case there is a match in the calltype analysis table, but once the 100 is added to the number, it doesn't know where to route it. Adding 100 with a min and max length of 7 and the desired route patteern resolved the issue.

Solution

added string match 2799 length 4 max 4 to form by typing "change calltype analysis".  Change this based on customer needs.

Additional Relevant Phrases

Not able to perform outbound call (internal - external) error message calltype 1031#, no match can't make outgoing call.

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