ACR : Agent Cannot Capture Screen


Doc ID    SOLN279328
Version:    22.0
Status:    Published
Published date:    01 May 2022
Created Date:    23 Nov 2015
Author:   
chengdongzhao
 

Details

ACR releases 12.0/12.1/15.1/15.1

New install of screen capture client to agents desktop pc but no screen recordings.

QM playback results in audio delivery but the screen capture does not play and error occurs "Due to an internal error you will not be able to playback.  Notify the system administrator"

Problem Clarification

From the client PC, the screen capture log ( C:/CaptureService/Screen Capture Module/logs/captureservice.log)  kept showing errors as below:

This may be occurring for 2 reasons:
1.  Please check the client PC firewall setting and make sure port 4001 opened or disable firewall.
2.  If these errors are found on a new install of the screen capture service is it likely occurring because specific registry keys were not added.


[captureser|0824|W] 2015/10/19 17:00:37.328  CActiveInteractiveUserFinder::GetProcessData() OpenProcess failed Error Code = 5 idx=1  pid=4
[captureser|0824|W] 2015/10/19 17:00:37.328  CActiveInteractiveUserFinder::GetProcessData() OpenProcess failed Error Code = 5 idx=16  pid=1156
[captureser|0824|I] 2015/10/19 17:00:37.328   CActiveInteractiveUserFinder::GetSessionData() This is an active session. LogonType=2
[captureser|053C|I] 2015/10/19 17:01:03.432  CNTService::Handler. OpCode=4 string="SERVICE_CONTROL_INTERROGATE"

Another symptom may include the following error during QM error on playback "Due to an internal error you will not be able to playback.  Notify the system administrator".

If this is occurring and the QM audio is working find the ContactID and acquisition module (identifies the serial number that performed recording) of this record.  The likely cause is that there are .scn files that are 1KB in size and contain no actual screen capture data so the error occurs.  This is likely to occur because the two process “WCapW32.exe” & “WcapWlistener.exe” on the agent's pc are not running and the above error is found in the screen capture log and task manager will not show these running.

Cause

- Port 4001 was blocked in client PC, it caused ACR cannot access the client PC with port 4001 for screen recording. 
- In a similar issue it has been observed that the test desktop had issue with Virtual network card which prevented 4001 from being properly opened and also observed that the administration of the desktops with ACR or WFO was not complete.
- Screen Capture software not installed with administrative privileges.
- Screen Capture software corruption.
- Station was not added to the Workstation Group tab of the WFO Data Source configuration page.

Solution

Port 4001 (from client PC)/29522 (from ACR server) will be used for screen capture process by default, it need to be opened for screen recording function.

There’s service “Capture Service” should be in started state, and two process “WCapW32.exe” & “WcapWlistener.exe” can be found from Windows task manager. It should be exclude from Anti-Virus app. Also occurs if screen capture client not installed with administrator privileges.

When there's problem that capture service can startup but listenser process cannot startup, check Windows registry setting HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\, make sure Userinit set with “C:\Windows\system32\userinit.exe,C:\CaptureService\Screen Capture Module\wcapwlistener.exe”.

Install latest Screen Capture client as an administrator account or right click and choose "Run as Administrator".  Please note the option to "Run as Administrator" may not be available as it is restricted by group/local pc policy.

In a similar case, Following development's observation and recommendation by adding stations in the Workstation Group tab of the WFO Data Source configuration page allowed the users’ screen data to be captured by the ACR.

Make sure that the Microsoft C++ 2008 Distribution is installed on the computer.  It is a required patch for the WcapW32.exe to run.

Try removing and re-adding the agent profile in both ACR and WFO.

 

review the following as well:

 It should be excluded from Anti-Virus app.

1. Connection between ACR and Desktop

2. Make sure the 3 process are running correctly on the desktop = Wcap32,Wcaplistener and Screencapture

3. make ACR can see Logon event from the desktop.


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