CM: Call Forward settings on SIP endpoints are ignored by CM thus call forwarding and coverage paths do not work


Doc ID    SOLN280051
Version:    6.0
Status:    Published
Published date:    02 May 2018
Created Date:    05 Dec 2015
Author:   
Levente Szabo
 

Details

CM 6.3.112.0-SP112
SM/SMGR 6.3.14
96xx SIP endpoints: Avaya one-X Deskphone 7.0.0.39 (39)
E129 SIP endpoints: 1.25.1.1

SMGR: 7.0.0.0.4119
SM:  7.0.0.0.700007
CM: 7.0.0.1.0-SP1
Avaya One-X Communicator: 6.2.7.03
H175: H1xx_SIP-R1_0_2_2_0102.tar

Problem Clarification

1.) The issue with call forwarding happens across all SIP phones,
both E129 and 96xx models.
The SIP phones do not appear to be picking up the CM features on an
inbound call. They are however, picking  other features such as buttons.
They can set and remove the forward, since we can see from the CM that it has been activated, but
the incoming calls just seem to ignore it. The result of this means that call
forwarding and coverage paths do not work.

Note: "list trace station" does not give any output.
 
2.) It has been noticed that the E129 phones can be forwarded using the call forward
option built into the phone, however if forwarded to the Messaging System, the mail system does
not recognize the station number that the call has been forwarded from.

Cause

Incorrect configuration.

Regarding point 1:
User has 'UDP Extension Search Order: udp-table-first' in their "dialplan parameters" form. With this entry the extension has to be entered in the "uniform-dailplan" table. On the "uniform-dialplan" form the extension range was defined, however the 'Net' parameter was set to 'aar' and 'Conv' was set to 'y'. This means CM will pass inbound calls to the extension numbers -defined as described above- over to AAR table right away and tries to route the call as per AAR table dictates. In this case CM sent the call to SM which passed the call to the station. Thus the call ended up on the called station and has never got forwarded.

Regarding point 2:
E129 stations have their own built-in call forward mechanism. If call forward is enabled using this call forward
option built into the phone then it is the SIP station itself that performs the call forward. So this way the call is forwarded, but looks like the info in the generated SIP message will not contain all the necessary bits for the voice mail system to map the call to the correct subscriber box.

On the other hand, when call forward is activated by dialling the CM feature access code (FAC), then it is CM itself that performs the call forward. Now with that, we are back to point #1 and call forward will not work.
 

Solution

Enter the extension range in the "uniform-dialplan" table with 'Net' set to 'ext' and 'Conv' set to 'n'. A sample configuration showing the main points:

display dialplan parameters

                             DIAL PLAN PARAMETERS
 
                 Local Node Number: 1                   ETA Node Number:
   UDP-ARS Calls Considered Offnet? n               ETA Routing Pattern:
        UDP Extension Search Order: udp-table-first

 

 

display uniform-dialplan 4                                      Page   1 of   2
                       UNIFORM DIAL PLAN TABLE
                                                              Percent Full: 0
 
  Matching                      Insert              Node
  Pattern       Len Del      Digits     Net Conv Num
    4000            6   0                       aar  y   <<<<< change this to 'ext'  'n'

Additional Relevant Phrases

sip phones don't cover to its coverage path; SIP calls not following coverage; call forwarding and coverage paths do not work on sip phones;

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