ACCS\AACC 6.4- unable to login into CCMA


Doc ID    SOLN283437
Version:    1.0
Status:    Published
Published date:    24 Mar 2016
Author:   
joselag
 

Details

CCMA login failure after migrating CCMA data from NES Contact Center 6.0, New deployment\Migration of ACCS 6.4 SP15. Unable to login to CCMA post NES 6.0 migration, Appears that the password is not being updated during the migration process. We did not get any errors during the migration and most of the logs show the ‘Webadmin’ account being updated to ‘Administrator”.

Problem Clarification

Unable to login into CCMA

2016-01-20 12:39:12.821-05:00 CCMA_AMLToACCSMigration 1 0 Trace    AMLtoACCSMigration               isAMLACCSMigrationFlagAlreadyPopulated AMLACCSMigration=1 Flag not found.
2016-01-20 12:39:12.822-05:00 CCMA_AMLToACCSMigration 1 0 Trace    AMLtoACCSMigration               ldapBIND                         Successful bind with path : LDAP://localhost:389/CN=webadmin,OU=Users,OU=ICE,O=NortelNetworks,dc=nortelnetworks,dc=com
2016-01-20 12:39:12.822-05:00 CCMA_AMLToACCSMigration 1 0 Trace    AMLtoACCSMigration               isAMLtoACCSMigration             webadmin user found...check for lockdown...
2016-01-20 12:39:12.823-05:00 CCMA_AMLToACCSMigration 1 0 Trace    AMLtoACCSMigration               isAMLtoACCSMigration             webadmin lockdown FALSE...
2016-01-20 12:39:12.829-05:00 CCMA_AMLToACCSMigration 1 0 Trace    AMLtoACCSMigration               isAMLtoACCSMigration             Conditions satisfied for AMLtoSIP migration...TRUE
2016-01-20 12:39:12.843-05:00 CCMA_AMLToACCSMigration 1 0 Trace    AMLtoACCSMigration               getLocalIP                       Successfully retrieved IP Address [10.210.27.11]
2016-01-20 12:39:12.843-05:00 CCMA_AMLToACCSMigration 1 0 Trace    AMLtoACCSMigration               removeServersAllExceptCCMS       Identify non-CCMS servers for removal
2016-01-20 12:39:12.859-05:00 CCMA_AMLToACCSMigration 1 0 Trace    AMLtoACCSMigration               encryptCredentials               encryption not required
2016-01-20 12:39:12.882-05:00 CCMA_AMLToACCSMigration 1 0 Trace    AMLtoACCSMigration               encryptCredentials               Server Credentials successfully encrypted
2016-01-20 12:39:12.898-05:00 CCMA_AMLToACCSMigration 1 0 Trace    AMLtoACCSMigration               addServers                       Successfully added servers.
2016-01-20 12:39:12.900-05:00 CCMA_AMLToACCSMigration 1 0 Trace    AMLtoACCSMigration               removeAccessClasses              Removing Access Class [CN=Supervisor]
2016-01-20 12:39:13.050-05:00 CCMA_AMLToACCSMigration 1 0 Trace    AMLtoACCSMigration               parseXML_AccessClasses           XML...Access Class [<AccessClass
2016-01-20 12:39:13.222-05:00 CCMA_AMLToACCSMigration 1 0 Trace    AMLtoACCSMigration               convertWebAdminToAdministrator   The object already exists.
2016-01-20 12:39:13.226-05:00 CCMA_AMLToACCSMigration 1 0 Trace    AMLtoACCSMigration               lockoutWebAdmin                  The object already exists.
2016-01-20 12:39:13.266-05:00 CCMA_AMLToACCSMigration 1 0 Trace    AMLtoACCSMigration               createACCSSyncUser               Successfully created accssync
2016-01-20 12:39:13.275-05:00 CCMA_AMLToACCSMigration 1 0 Trace    AMLtoACCSMigration               operateOnUsers                   name [aboling], iceCCMAProfile [aboling], givenName [Amy], sn [Boling], iceParameters [001110000], iceRoleType[2]

 

CCMA80_upgrade.log

Updating report owner: From = webadmin, To = administrator
----------------------------------------------------------------
Finished updating report owner: Reports Updated = 38

RunAMLACCSMigration - complete. See CCMA_AMLToACCSMigration_1.log for details
RunAMLACCSMigration Migration(): Complete at :1/20/2016 At 12:39:18 PM
---------------------------------------
Delete Nortel folder after upgrade
Fail to remove Nortel folder.
-------------------------------------------------

Upgrade complete.


CCMA_ADLDSUpdatesDotNet_1.log


ADLDSUpdatesDotNet LOGGING STARTED #########################################
2016-01-20 12:34:40.452-05:00 CCMAADLDSUpdatesCSharp 1 0 Trace    ADLDSUpdatesDotNet               isIPOFFICE                       ACCS identified...
2016-01-20 12:34:40.452-05:00 CCMAADLDSUpdatesCSharp 1 0 Trace    ADLDSUpdatesDotNet               isSecondaryInstance              Primary AD/LDS instance identified. Continuing...
2016-01-20 12:34:40.453-05:00 CCMAADLDSUpdatesCSharp 1 0 Trace    ADLDSUpdatesDotNet               connectToADLDSInstance           Successful connection to AD/LDS with path : LDAP://localhost:389/dc=nortelnetworks,dc=com
2016-01-20 12:34:40.485-05:00 CCMAADLDSUpdatesCSharp 1 0 Trace    ADLDSUpdatesDotNet               ldapBIND                         Successful bind with path : LDAP://localhost:389/OU=AccessClasses,OU=ICE,O=NortelNetworks,dc=nortelnetworks,dc=com
2016-01-20 12:34:40.490-05:00 CCMAADLDSUpdatesCSharp 1 0 Trace    ADLDSUpdatesDotNet               ldapBIND                         Failed to bind with path : LDAP://localhost:389/CN=administrator,OU=AccessClasses,OU=ICE,O=NortelNetworks,dc=nortelnetworks,dc=com
2016-01-20 12:34:40.490-05:00 CCMAADLDSUpdatesCSharp 1 0 Trace    ADLDSUpdatesDotNet               getADLDSHandles                  Failed to bind to CN=administrator..null returned


CCMA_WClient_DA_COM_ WClient_DA_COM_1.log

2016-01-20 12:55:34.138 0    WARN  WClient_DA_COM pid=16256 tid=2648 WClientDataAccess opUserAttributes 80040BCB:administrator; Password missing
2016-01-20 12:55:47.425 0    WARN  WClient_DA_COM pid=16256 tid=2648 WClientDataAccess opUserAttributes 8000500D:webadmin:LDAPDomain; ADSI Error; The directory property cannot be found in the cache.
2016-01-20 12:55:47.460 0    WARN  WClient_DA_COM pid=16256 tid=2648 WClientDataAccess opUserAttributes 8000500D:webadmin:LDAPDomain; ADSI Error; The directory property cannot be found in the cache.
2016-01-20 13:03:20.025 0    WARN  WClient_DA_COM pid=16256 tid=2648 WClientDataAccess opUserAttributes 80040BCB:administrator; Password missing
2016-01-20 13:03:33.205 0    WARN  WClient_DA_COM pid=16256 tid=2648 WClientDataAccess opUserAttributes 80040BCB:administrator; Password missing
2016-01-20 13:03:45.369 0    WARN  WClient_DA_COM pid=16256 tid=2648 WClientDataAccess opUserAttributes 8000500D:webadmin:LDAPDomain; ADSI Error; The directory property cannot be found in the cache

****Steps to reproduce****

Followed the steps on page 20 of the Avaya Aura Contact Center CS1000 (AML) to Avaya Contact Center Select (IP Office) Migration Guidelines Upgrade the Avaya NES CCMA database, or the AACC 6.2, 6.3, or 6.4 database, to ensure compatibility of existing databases with the new Contact Center Manager Administration software for Avaya Contact Center Select.

1) On the new ACCS server, choose Start > All Programs > Avaya > Contact Center > Manager Administration > Configuration.
2) In the left pane of the Avaya Configuration window, expand Avaya > Applications > CCMA System Upgrade Utility.
3) In the right pane, click CCMA System Upgrade Utility.
4) Click Yes.
5) In the CCMA Upgrade Utility, click Browse to navigate to the location containing the old
CCMA data that was restored either using the Windows NT Backup Restore utility or as part of a standard restore from AACC 6.2, 6.3, or 6.4.
6) Click Upgrade. The following message should be displayed:
Note: When the utility has successfully run, the results relating to the AML to ACCS Migration appear in CCMA_AMLToACCSMigration_1.log, available in the D:\Avaya\Logs\CCMA folder.
7) Close the Upgrade Utility application.

Administration Configuration:

1) Log on to the Avaya Contact Center Select server as the system Administrator account.
2) On the new Avaya Contact Center Select server, right-click on the SMMC System tray on the Windows Task bar and click Start System. When the system has started, the SMMC System tray will change to a ‘Running’ state.
3) When the system has started, log on to Contact Center Manager Administration with Administrative privileges.
4) The Avaya Contact Center Select – Migration Completion page is displayed.
5) On the Migration Completion page, confirm which server is the new Avaya Contact Center Select server by clicking the Select button
6) Click Complete Migration.
7) Click Confirm Migration. The following will be displayed:
8) Once the migration is complete, Click Continue to Launchpad.
 

 

Cause

Root cause has been identified, issue is the fact the customer has an Administrator account in the NES 6.0 CCMA. Design is working on a patch to create an alternative Administrator account if issue is encountered.


For the login issue the legacy administrator user in CCMA is to be renamed - fix in 7.x
On 6.4, customer has solved the login issue by deleting the account in legacy administrator user in NES6 CCMA.

Solution

Root cause has been identified, issue is the fact the customer has an Administrator account in the NES 6.0 CCMA.  For the login issue the legacy administrator user in CCMA is to be renamed - fix in 7.x
On 6.4, customer has solved the login issue by deleting the account in legacy administrator user in NES6 CCMA.

Attachment File

unable to login.png
0Bytes • < 1 minute @ 56k, < 1 minute @ broadband



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