Secure Access Link: SPIRIT Agent Start FAILED: Index: 0, Size: 0


Doc ID    SOLN284840
Version:    4.0
Status:    Published
Published date:    20 Apr 2016
Created Date:    01 Mar 2016
Author:   
Lauren Mitchell
 

Details

 

All versions of Secure Access Link Gateway (SALGW).

Web interface of the SAL Gateway states SAL Agent not running, will not restart from web, "error current operation failed". Cannot restart the spiritAgent from the command line, syslog error occurs;

Message from syslogd@ at Wed Feb 24 14:15:27 2016 ...
hostname local:<8>Feb 24 14:15:27 client.corp.com SPIRITAgent[noProcessID]: +00:00 2016 097 1 com.avaya.spirit.util.logging.SPIRITCommonLogger | 1 com.avaya.spirit.agent.logging O_AG-AG0017 O_AG-AG0017 SPIRIT Agent Start FAILED: Index: 0, Size: 0

Problem Clarification

 

Unable to add new managed elements, restart services from the web interface. The current operation fails.

Cause

 

There was a typo in the Product/ Alarm ID in at least one of the SAL configuration files.

As an example of how this can occur; The End User initially installed two SALs with the exact same Solution Element ID (SEID) and Product ID (Product ID, same as Alarm ID).

Solution

 

Access the web interface of the SAL and the End User should be able to edit the SEID/Product ID.

Additional Relevant Phrases

GUI shows SAL Agent not running, added new ME but SAL will not restart from GUI, error current operation failed.

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