Avaya Aura Communication Manager - Incoming text notification from iPhone causing interruption in voice path of call


Doc ID    SOLN285595
Version:    6.0
Status:    Published
Published date:    29 Nov 2019
Created Date:    14 Mar 2016
Author:   
jschug
 

Details

Customer reporting that they have noticed the iPhone default text notification tone (at the link below) causes the CM to interpret and send a fax request during the call.  This then interrupts some or all of the voice paths in the call.

Reported Scenario  2:

 CM Reports as:  R015x.02.1.016.4
 CM Release String:  S8800-015-02.1.016.4
 Avaya Phone type - 9650 and 1408

Description of call flow:
1. There are two phones. Subscriber A has the model 9600. Subscription B has a different model.
2. Subscriber B calls Subscriber A to the telephone.
3. Subscriber A on the 9650 series answers the call through the speakerphone.
4. There is a conversation between two people - one through the speakerphone (Subscriber A at 9650), Subscriber B through the handset.
5. Subscriber A with the 9650 device receives some kind of message on his cell phone and he plays a note (Note melody from IPhone) melody.
6. After playing this melody, Subscriber A on the 9650 will mute the microphone and speakerphone.
7. Subscriber B stops hearing Subscriber A in the handset of his device

Trace of Call impacted - There is nothing in a regular trace. just the fact of the call and the start of the conversation.
Issue is only with Avaya phones 9650/1406) - The problem is observed on any device.
The customer does not use EC500 or One x Mobile/Equinox. Tha calls ares made inside the CM station - i.e. one extension is calling another. And when talking, an one person receives an SMS on a cell phone and a melody is played - Note (in Iphone model).

 https://www.youtube.com/watch?v=WnhWCVAAAKw

 
-Seems to affect all versions of CM 6.3.
-May affect other releases as well
 
 

Problem Clarification

IPhone text notification tone interpreted as a fax tone by CM.

Testing in Avaya lab confirmed this issue occurs depending on the codec settings for Fax and Modem.

In the list trace you will see:

 

12:31:18     G711MU ss:off ps:20
             rgn:240 [x.x.x.x]:8012
             rgn:1 [x.x.x.x]:26368
12:31:18     xoip options: fax:T38 modem:PT tty:US  uid:0x501a9
             xoip ip: [x.x.x.x]:26368 
12:31:20     Start Modem PassThru aux:none tone:Ansam uid:0x501a9

wrongly patch line cord during the replace FAX machine

Cause

 

CM is detecting a 2100Hz tone from the iphone and that is the same frequency as the CED tone which a Fax machine transmits after answering a call.
If the call was shuffled between IP/SIP phones with no medpros or gateways in the connection path, this could not happen.
But when a medpro/gateway is listening, and the codec set has t.38 fax enabled, this tone will trigger the fax feature.

We cannot change that frequency as it is standard around the world. So we see no way to change CM to prevent this from happening except modifying the codec-set.
Otherwise, the user would have to either change the text tone or make the phone silent.

Solution

The root cause of the issue is that the terminating fax tone is interpreted as a modem tone by the local DSP.

Tier4 recommendation is that ip-codec-sets have either fax or modem capabilities, but not both. Ideally modems and fax machines should have unique network regions and codec sets.

For internal calls where an IGC connection is made between PN and/or MG, the CM always uses Avaya proprietary fax pass thru mode. Hence, internal fax (same MG/PN), IGC fax internal or out PRI, etc are not impacted and complete as expected.

For outgoing SIP fax calls, the network region is determined by the signaling group's far-end network region. The ip-codec-set used is determined by ip-network-region based on the signaling group's far-end NR and the originator's NR.

For incoming SIP fax calls, the network region of the far-end is determined in order of precedence: presence of SDP media IP in ip-network-map, then the far-end NR from the SIP trunk signaling group, then the near-end NR. 

 

If this does not work especially for analog endpoints if other end will never need fax or modem make the following changes.

On the SIP trunk group page 2 in the field XOIP Treament set to TTY

On the station page for analog extensions such as conference room speaker phones on page 1 set the field XOIP Endpoint Type to TTY.

This will allow TTY devices to still function on the trunk groub, but not modems and fax machines.

Additional Relevant Phrases

Iphone Text message causes call to drop;Iphone defualt message causes call to drop,conference call drops when Iphone text message received

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