[CM] Customer hears beep tone while call is engage. Logs showed DTMF tone is being sent even after the call is established.


Doc ID    SOLN285774
Version:    3.0
Status:    Published
Published date:    12 Mar 2020
Created Date:    16 Mar 2016
Author:   
pcanonce
 

Problem Clarification

The customer has a dedicated trunk for outgoing calls to mobile phones.   When using this trunk they hear a beep during conversation.   Sometimes the call is already engaged 3 to 10 minutes then all of a sudden they hear a beep. This happens on 8 out of 10 calls.

Cause

A list trace confirms that there is a digit 3 being sent when customer complains that they are hearing beep.  

list trace station 7733                                                Page   1
                                LIST TRACE
time            data
14:27:55 TRACE STARTED 02/22/2016 CM Release String cold-03.0.124.0-22450
14:28:32     active station      7733 cid 0x25a3
14:28:32     G711MU ss:off ps:20
             rgn:1 [10.200.92.60]:19278
             rgn:1 [10.200.22.17]:56648
14:28:39     short inter-digit delay due to overlapping entries  cid 0x25a3
14:28:39     dial 909174080516# route:ARS
14:28:39     term trunk-group 61      cid 0x25a3
14:28:39     dial 909174080516# route:ARS
14:28:39     route-pattern  13 preference 1 location 1/ALL  cid 0x25a3
14:28:39     seize trunk-group 61 member 2    cid 0x25a3
14:28:39     Setup digits 09174080516
14:28:39     Calling Number & Name NO-CPNumber Telephony
14:28:39     Proceed trunk-group 61 member 2    cid 0x25a3
14:28:39     Alert trunk-group 61 member 2    cid 0x25a3
.....
14:41:05     digit 3 originated by trunk-group 61 member 2  cid 0x25a3
14:41:05     digit 3 sent to station    7733 cid 0x25a3

If I checked the MST I see this error being thrown out when the beep sound is heard.  
#define CM_DELAY_ESIG_TMO * Delay time before esiging the first
                          * in-band or rtp-payload digit after
                          * obtaining a media resource.

14:41:05.938  40 Internal Call Process  (154 msg bytes)
CONNM [000025a3] CM_DELAY_ESIG_TM

Solution

Testing helped isolate the issue.
- An outbound call to mobile using a different trunk has no such tone
- Using the problem trunk to call any phone can produce the beep.

It appears that it is the Telco who is inducing the beep tone on this trunk.  Per BP there is Telco equipment that connects to the DS1 .   

I asked BP to connect an analog phone directly to the Telco equipment and see if this is producing the beep.

Telco will need to resolve this issue.

Additional Relevant Phrases

beep tone.

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