Aura Messaging IMAP failures due to File Descriptor leak - "there is a problem with the system" when trying to log into a mailbox.


Doc ID    SOLN286073
Version:    5.0
Status:    Published
Published date:    06 Oct 2017
Created Date:    22 Mar 2016
Author:   
Adam MacKenzie
 

Details

AAm 6.3.2 SP2 Patch 5

AAM 6.3.1 SP1 - VMWare

Corrected in AAM 6.3.3.x

Servers are installed on customer hardware and VMware. CPU and Memory reservations are not set to the recommended settings in the AAM in a VMware environment.

Problem Clarification

End users report that while trying to access voicemail there hear "there is a problem with the system". They admin reboots the systems to correct the problem. This problem has been occurring for 6 weeks. When these problem occur, Mango 42 and 43 alarms are generated (Ldap and Imap major alarms). No core dumps.

Internal error when trying to open Greetings Page from User Preference - system wide any user

also when users access voicemail system the automated message states that "not all functionality is available at this moment and to contact a system administrator" AAM answering in offline mode - unable to delete messages

Cause

Connection between Application Server and Storage Server drops due to IMAPD being under stress due to requests taking a very long time. Some of these requests are IMAP4 failed authenitcation requests.

Solution

Issue does not occur in Aura Messaging 6.3.3.x. Development has tested the issue and found issue to be corrected in 6.3.3 SP5 as well as 7.0

Additional Relevant Phrases

Some features are not available. Messaging restarts

Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy