AACC 6.4 Sp 15: Contact Summary Report missing DNIS value on Second Leg of call


Doc ID    SOLN287269
Version:    1.0
Status:    Published
Published date:    02 May 2016
Author:   
welton
 

Details

Contact Summary Reports, do not appear to be capturing the DNIS in the Address field for the SECOND LEG of a call,

Problem Clarification

AACC 6.4 Contact Summary Report shows the CDN value on the second leg of the call.

Call Flow:

External call presented to AACC to CDN (DNIS value in the ICC AML log) . This call is routed via AACC Scripting to a Third party mail system (IVR). The third party Application then transfers the call back into AACC Via CDN (AML ICC does not show DNIS value). When the transfer is completed the DNIS value is presented to the Agent display.

1) AML log for incoming second leg does not show DNIS as terminating DN value and Terminating DN type is CDN

[Aml    ]-> ===========================================================================================================
--------    Input                       Thu Mar 31 12:31:24.300 2016   (31:24.300)  (Delay = 0msecs)
ICC
                  03 48 00 00 00 00 1e 38 6a ef 00 00    header (12 bytes)
                                    96 04 02 37 3f d4    Call Id (37175252)
                              30 06 77 aa f7 81 10 00    Originating DN (7700/7811)
                                             3d 01 0c    Originating DN Type (ACD DN/ACD Pos)
                                    31 04 74 26 51 10    Terminating DN (7426511)
                                             3e 01 16    Terminating DN Type (CDN)
                                             32 01 01    Call Type (direct)
                                          4d 02 1b 90    Xfered Party TN
                                             4f 01 09    Xfered Party DN type (route/member)
                                    4c 04 79 a1 f1 17    Xfered Party DN (7901/117)
                                          4e 02 26 51    Xfered Party DNIS
                                    53 04 02 37 3e 27    Xfered Party Call Id (37174823)
                           5f 07 1f 03 14 10 0c 1f 17    Timestamp
===========================================================================================================

2) EB logs does not show the DNIS value on the Incoming call Details

[EB     ]-> ----------------------->> Message received <<-------------------------------
2016-03-31 12:31:24.303
msgType : NICOM_clLocalCallArrived
m_wSwitchId : 0
m_byCustomerNo : 0
m_acCreatorProcess : nitfe
m_wCallHandle : 37175252
m_wSwitchNodeId : 0
m_wSwitchLocalCallId : 37175252
m_ulEventTime: Thu Mar 31 12:31:24 2016
m_ulCallType: 3
m_wNetworkCallId: 0
m_wInterCallId: 37174823
m_wApplicId: 1
m_acCDN: 7426511
m_wRouteNo: -1
m_wTrunkId: 0
m_acDNIS: 
m_acCLID: 7700
m_byCallModification: 1
m_wContactType: 10000
m_acUUID: 
m_acProviderId: 
m_acProviderContactId:

2) the HDC log shows the CSR (Contact Summary Report) being updated- No DNIS value

----------------------->> Message received <<-------------------------------
2016-03-31 12:31:24.307
msgType : NICOM_clLocalCallArrived
m_wSwitchId : 0
m_byCustomerNo : 0
m_acCreatorProcess : nitfe
m_wCallHandle : 37175252 m_wSwitchNodeId : 0
m_wSwitchLocalCallId : 37175252
m_ulEventTime: Thu Mar 31 12:31:24 2016
m_ulCallType: 3
m_wNetworkCallId: 0
m_wInterCallId: 37174823
m_wApplicId: 1
m_acCDN: 7426511
m_wRouteNo: -1
m_wTrunkId: 0
m_acDNIS:
m_acCLID: 7700
m_byCallModification: 1
m_wContactType: 10000
m_acUUID: 
m_acProviderId: 
m_acProviderContactId:  ====================================================================================

---> 2016-03-31 12:31:24.308 [.\NIHDC_clCDR.cpp-107]                        [Trace] Creating CSR, SequenceID = [3852467]
---> 2016-03-31 12:31:24.308 [.\NIHDC_clCallPegInfoMgr.cpp-111]             [Call Manager Trace] Call PegInfo Added
 CallId : 37175252
 Total Call Objects: 37

Cause

Working as designed- the DNIS is not presented in the EB logs until the Transfer is completed

44400-117_05.03_AACC_Performance_Management_Data_Dictionary_December_2014.pdf states  the Address Value " this is a DNIS number, or a CDN number if no DNIS number is available". At the time of the creation of the entry there is no DNIS available

Solution

AACC Working As Designed


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