CM : EC500 call not working if CM receives "500" SIP response from SM within EC500_DELAY_TMR timer expires


Doc ID    SOLN288413
Version:    3.0
Status:    Published
Published date:    30 May 2016
Created Date:    28 Apr 2016
Author:   
Andreas Voigt
 

Details

Avaya Aura Communication Manager 6.3 - SP12

Problem Clarification

It’s about Avaya Communicator for Android on a mobile phone with VoIP Call. CES activated and Ring-Also goes to mobile phone.

When I lose data connection to SBCE on my mobile phone, SBCE sends a “service unavailable” back to CM. CM immediately creates a new call to my mobile phone number, but that call fails:

The connection between the Android and the SBC was dropped and then we started the test calls:

Call1: Calling party 0xxxxx1255. Called party ext 9313 UID 8C96  tries to reach the Android but SBC replies Service Unavailable, then CM starts the EC500 call, Android rings and shows the number 9313, after going off-hook at the Android end you hear ringback at the Android and the caller at 0xxxxx1255 hears ringback as well.

Call2: Calling party 0xxxxx1255. Called party ext 9313 UID 8C96 CM uses EC500 to reach the Android. It rings, shows the calling party number 0xxxxx1255 and not 9313 as before and when you pick up the call you get normal talkpath.
When waiting 15 seconds after the connection between the Android and the SBC was dropped the first call works fine as well.

Cause

Avaya Aura Communication Manager software bug

Solution

The Fix for this will be included in Service Pack 15 for Avaya Aura Communication Manager 6.3, scheduled to be released on the 29th of August 2016.


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