OneX Communicator: No button labels are downloaded and displayed when OneX Communicator is registered in MyComputer SIP mode


Doc ID    SOLN288786
Version:    3.0
Status:    Published
Published date:    17 Dec 2020
Created Date:    04 May 2016
Author:   
aa1
 

Details

Avaya Aura® Session Manager Release: 7.0.0.2.700201
Avaya Aura® Communication Manager Release: R017x.00.0.441.0
Avaya Aura® System Manager Release: 7.0
Avaya one-X® Communicator R6.2 Service pack 11 -Patch 2(6.2.11.05)

This might apply to other versions of Avaya Aura solution

Problem Clarification

Avaya one-X® Communicator with SIP extension registered in "MyComputer" mode does not show the button labels. However, when Avaya one-X® Communicator with SIP extension registers in "DeskPhone" mode, then the button labels are displayed on Avaya one-X® Communicator. Reference to the screen shot below, the area marked with red demonstrates the missing button labels

 

Cause

Mismatch in the System Manager certificate administration. As a result, OneX Communicator and Session Manager failed to complete the PPM TLS handshaking.

Solution

Administration on System manager contains invalid value. As a result, OneX Communicator does not recognize the Common Name in the certificate. When this  happens, the PPM handshaking between Session Manager and OneX Communicator fails and therefore the button label info is not transmitted from Session Manager to OneX Communicator.

Check the "Common Name" on System Manager at: "Home / Services / Inventory / Manage Elements under Replace Identity Certificate" and ensure the value is correct. To  confirm the signature of this issue, a traceSM trace may be captured on Session Manager with PPM option. The key is to look for TLS handshaking failing

Additional Relevant Phrases

No button labels on OneX Communicator

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