CM: trunk to trunk call fail between the Ericsson MD110 and the Cisco Call Manager through CM


Doc ID    SOLN288863
Version:    3.0
Status:    Published
Published date:    05 Jul 2016
Created Date:    05 May 2016
Author:   
Yuriy Drumov
 

Details

unsuccessful call:
3rd party PBX Ericsson MD110 =>QSIG isdn-pri  trunk 222 =>CM 5.2.1 => isdn H.323  trunk 32 =>  3rd Party PBX Cisco Call Manager

successful call:
3rd Party PBX Cisco Call Manager => isdn H.323 trunk => CM 5.2.1 =>  QSIG isdn-pri  trunk  =>3rd party PBX Ericsson MD110

              Voice System name: 01. Main - LIST TRACE                      
                                                                             
time            data                                                            
??|7?                                                                        
11:29:15     Calling party trunk-group 222 member 1    cid 0x3b26              
11:29:15     Calling Number & Name 849596 NO-CPName                            
11:29:15     active trunk-group 222 member 1    cid 0x3b26                      
11:29:15     dial 841500 route:UDP|AAR                                          
11:29:15     term trunk-group 32      cid 0x3b26                                
11:29:15     dial 841500 route:UDP|AAR                                          
11:29:15     route-pattern  32 preference 1 location 184/ALL  cid 0x3b26        
11:29:15     seize trunk-group 32 member 2    cid 0x3b26                        
11:29:15     Setup digits 841500                                                
11:29:15     Calling Number & Name 849596 NO-CPName                            
11:29:15     xoip options: fax:off modem:off tty:US  (igc)                      
          xoip ip: [10.36.193.5]:2110                                        
11:29:15     xoip options: fax:off modem:off tty:US  (igc)                      
          xoip ip: [10.219.102.20]:2800                                      
11:29:15     Proceed trunk-group 32 member 2    cid 0x3b26                      
                                                                             
                                                                             
                                                                             
                             LIST TRACE                                      
                                                                             
time            data                                                            
11:29:15     Alert trunk-group 32 member 2    cid 0x3b26                        
11:29:15     idle trunk-group 222 member 1    cid 0x3b26                        
11:31:06 TRACE COMPLETE trunk-group  222 cid 0x0    

Problem Clarification

3  09:52:14.508  62 40de100f <-- ALERT      crv 1_67e6  
          D-channel port number:                                   40de100f
          Protocol Discriminator: 08                           call control
          Call Reference Value: 02 e7 e6                   Destination 67e6
          Q.931 Message Type: 01                                   Alerting
  4  09:52:14.509  62 40de100f <-- NOTIFY     crv 1_67e6  
          D-channel port number:                                   40de100f
          Protocol Discriminator: 08                           call control
          Call Reference Value: 02 e7 e6                   Destination 67e6
          Q.931 Message Type: 6e                           Notify <<CCITT>>
     <-   NOTIFICATION INDICATOR <<CCITT>>                           1 byte
          | f1

  5  09:52:14.579  60 40de100f ==> STATUS     crv 0_67e6  incompat !
          D-channel port number:                                   40de100f
          Protocol Discriminator: 08                           call control
          Call Reference Value: 02 67 e6                   Origination 67e6
          Q.931 Message Type: 7d                                     Status
     =>   CAUSE user:                 101. Msg incompatible with call state

Ericsson does not "like"  NOTIFY messages and declines the call.

Cause

3rd party PBX Ericsson MD110

Solution

Message NOTIFY have to be disabled on the Erikson side.
CM only transfers all signaling messages and does not change them.

Note: Ericsson does not participate in DevConnect at a test-enabled membership level, and no DevConnect-based testing of the Ericsson MD-110 PBX has been done.

In this case, there is a protocol mismatch between CM and the Ericsson that we cannot resolve.


Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy