ACR: Calls Are Not Recording/Monitored


Doc ID    SOLN290389
Version:    1.0
Status:    Published
Published date:    01 Jun 2016
Author:   
Imaobong Ekwere
 

Details

ACR 12.0 Patch 197

ACR was not recording calls

Problem Clarification

The ACR was not recording calls.
This was a new install. When test calls were done, the ACR was not monitoring the device/ports.

Cause

From the acr logs found that ACR is calculating based on the 11 digits that the device is “external”, since external ACR will not put a monitor on that device.

This is why not recording.

2016-05-27 12:00:24,565 [TSAPIEvent-1] DEBUG com.swhh.csta.d.e - station 18476461300 onSnapshotCall=CSTASnapshotCallConfEvent
 info=CSTASnapshotCallResponseInfo
  deviceOnCall=ExtendedDeviceID
   deviceID=18476461300
   deviceIDType=explicitPrivateLocalNumber
   deviceIDStatus=idProvided
  callIdentifier=ConnectionID
   callID=10383
   deviceID=18476461300
   devIDType=staticId
  localConnectionState=csConnect
 info=CSTASnapshotCallResponseInfo
  deviceOnCall=ExtendedDeviceID
   deviceID=T10383#2
   deviceIDType=explicitPublicUnknown
   deviceIDStatus=idProvided
  callIdentifier=ConnectionID
   callID=10383
   deviceID=T10383#2
   devIDType=dynamicId
  localConnectionState=csConnect
2016-05-27 12:00:24,565 [TSAPIEvent-1] DEBUG com.swhh.csta.d.p - Conn=ConnectionID
 callID=10383
 deviceID=18476461300
 devIDType=staticId
2016-05-27 12:00:24,566 [TSAPIEvent-1] DEBUG com.swhh.csta.a.a.ab - Creating new external 18476461300
2016-05-27 12:00:24,566 [TSAPIEvent-1] DEBUG com.swhh.csta.a.c.i - New Conn: Conn:3, call=10383 external 18476461300 /ESTABLISHED May 27, 2016 12:00:24 PM REC

Solution

When sites use more than 10 digits, an acr.properties file setting is required to have ACR use other criteria to determine internal/external devices.

The setting is tsapi.numplanlength=11

This has been added and corrected the issue.


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