Communication Manager : Getting fast busy on outbound calls and denial event 1012 No circ chan avail


Doc ID    SOLN290732
Version:    5.0
Status:    Published
Published date:    20 Jul 2022
Created Date:    07 Jun 2016
Author:   
Mohammad Faraz
 

Details

AACC 7.0.1.1 SIP
CM 7.0.1.3

Problem Clarification

Multiple callers company wide getting a fast busy when outbound calling. According to career something wrong with pbx

Carrier indicates no problem on their end, and indicate a PBX issue. List trace shows no channel available.

If AACC agent is making the dialout attempt, SIP messaging appears as follows:
5744                                                                                                    3804 (CDN)         
|                                                                                                               |                  
|--------------------------------------------------------------------------------INVITE->|
|<-100 Trying---------------------------------------------------------------------------|
|<-180 Ringing--------------------------------------------------------------------------|
|<-408 Request Timeout (timeout matching contact for Agent orig call)|
|------------------------------------------------------------------------------------ACK->|
 

AACC is attempting to answer the call on the CDN, but the CM is not responding, so the request times out:

05/10/2017-10:21:53.126 --> message sent to 10.0.200.106:16847
Start-Line: SIP/2.0 408 Request Timeout (timeout matching contact for Agent orig call)
From: "Mary Smith"<sip:5744;[email protected];user=phone>;tag=b04e91a8-6725a8c0-13c4-55013-bab665-6853d4a9-bab665
To: <sip:3804;[email protected];user=phone>;tag=98106740-80c8000a-13c4-65014-133a5d-3debacc-133a5d
Call-ID: afc23628-6725a8c0-13c4-55013-bab665-76c04553-bab665
CSeq: 1 INVITE
Via: SIP/2.0/TCP 10.0.200.106;branch=z9hG4bK816118068534372-AP;ft=5
Via: SIP/2.0/TCP 10.0.200.105:15060;rport=26193;branch=z9hG4bK816118068534372;ibmsid=local.1485353016127_14396680_14526254
Via: SIP/2.0/TCP 10.0.200.105:15060;rport;branch=z9hG4bK706911678054444;ibmsid=local.1485353016127_14396679_14526253
Via: SIP/2.0/TCP 10.0.200.106;received=10.0.200.106;rport=25553;branch=z9hG4bK-bab665-d9587be8-1bf9707e-AP;ft=91790
Via: SIP/2.0/TCP 192.168.37.103:5060;branch=z9hG4bK-bab665-d9587be8-1bf9707e
Supported: timer,replaces
User-Agent: Avaya Aura Contact Center 7.0.0.0
Content-Length: 0
 

SipSp has:

05/10 10:21:50.623 [SgmSipProv      ] INFO  ortel.ccms.sgm.CallIdGenerator - generate() [CallId:37369601]
05/10 10:21:50.624 [SgmSipProv      ] INFO  l.ccms.sip.call.SipCallManager - createSipCall() C->J, peer=2210428512
05/10 10:21:50.624 [SgmSipProv      ] INFO  m.nortel.ccms.sip.call.SipCall - <init2>() Done. peer=2210428512, [SipCall:37369601]
05/10 10:21:50.624 [SgmSipProv      ] INFO  m.nortel.ccms.sip.call.SipCall - createCallLeg<3>() UAS: C->J [SipCall:37369601]
05/10 10:21:50.624 [SgmSipProv      ] INFO  ortel.ccms.sip.call.SipCallLeg - <init1>()  Done UAS [sipLeg:afc23628-6725a8c0-13c4-55013-bab665-76c04553-bab665][SipCall:37369601] 10.0.200.106:16847;TCP
05/10 10:21:50.624 [37369601        ] INFO  ortel.ccms.sip.call.SipCallLeg - sendProvisionalResponse() J->C [sipLeg:afc23628-6725a8c0-13c4-55013-bab665-76c04553-bab665], code=180
05/10 10:21:50.624 [SgmSipProv      ] INFO  ortel.ccms.sip.call.SipCallLeg - jni_setState() [sipLeg:afc23628-6725a8c0-13c4-55013-bab665-76c04553-bab665] OFFERED
05/10 10:21:50.624 [37369601        ] INFO  .protocol.sip.bbua.BbuaContact - <init>() [BbA:5744/agt], called=[BbA:3804/rp]
05/10 10:21:50.624 [37369601        ] INFO  .protocol.sip.bbua.BbuaContact - setControllerAddr() to [BbA:3804/rp]
05/10 10:21:50.624 [37369601        ] INFO  .cmf.sp.bbua.CilContactManager - contactCreated() [BbContact:37369601/M], calling addr  CTI-controlled
05/10 10:21:50.624 [37369601        ] INFO  tel.sgm.cmf.sp.bbua.CilAddress - setContactWaitingForCtiCreatedCmfContact() Store CilContact: [CilContact:null]
[…]
05/10 10:21:53.126 [37369601        ] ERROR ol.sip.bbua.BbuaContactManager - createCall() Timeout occurred matching CTI created contact, reject call with REQUEST_TIMEOUT
05/10 10:21:53.126 [37369601        ] INFO  ortel.ccms.sip.call.SipCallLeg - reject() J->C [sipLeg:afc23628-6725a8c0-13c4-55013-bab665-76c04553-bab665]
05/10 10:21:53.126 [37369601        ] INFO  ortel.ccms.sip.call.SipCallLeg - jni_setState() [sipLeg:afc23628-6725a8c0-13c4-55013-bab665-76c04553-bab665] DISCONNECTED
05/10 10:21:53.126 [37369601        ] ERROR m.nortel.ccms.sip.call.SipCall - createCallLeg<3>run()
java.lang.Exception: Error creating SIP call listener
 at com.nortel.sgm.SgmSipCallLegManager.sipCallLegCreated(SgmSipCallLegManager.java:84)
 at com.nortel.ccms.sip.call.SipCall$1.run(SipCall.java:433)
 at com.nortel.ccms.sgm.SgmTaskExecutor.run(SgmTaskExecutor.java:150)
 at com.nortel.ccms.sgm.SgmThreadPool$PoolWorker.run(SgmThreadPool.java:228)
05/10 10:21:53.126 [37369601        ] INFO  ortel.ccms.sip.call.SipCallLeg - setState() Report as Failure - Disconnect [sipLeg:afc23628-6725a8c0-13c4-55013-bab665-76c04553-bab665] from state IDLE
05/10 10:21:53.126 [37369601        ] WARN  ortel.ccms.sip.call.SipCallLeg - setState() Unhandled state transition
05/10 10:21:53.127 [SgmSipProv      ] INFO  ortel.ccms.sip.call.SipCallLeg - jni_setState() [sipLeg:afc23628-6725a8c0-13c4-55013-bab665-76c04553-bab665] TERMINATED
05/10 10:21:53.127 [37369601        ] INFO  m.nortel.ccms.sip.call.SipCall - removeCallLeg() [sipLeg:afc23628-6725a8c0-13c4-55013-bab665-76c04553-bab665] - last leg
05/10 10:21:53.128 [37369601        ] INFO  .protocol.sip.bbua.BbuaContact - sipCallInvalid() [SipCall:37369601]
05/10 10:21:53.128 [37369601        ] INFO  .protocol.sip.bbua.BbuaContact - drop() w/ Rc=DEFAULT
05/10 10:21:53.128 [37369601        ] WARN  tel.sgm.cmf.sp.bbua.CilContact - eventCallDropped() Already dropped
05/10 10:21:53.128 [37369601        ] INFO  .cmf.sp.bbua.CilContactManager - removeContact() null
05/10 10:21:53.128 [37369601        ] INFO  ortel.ccms.sip.call.SipCallLeg - destroy() J->C [sipLeg:afc23628-6725a8c0-13c4-55013-bab665-76c04553-bab665]
05/10 10:21:53.128 [37369601        ] ERROR ortel.ccms.sip.call.SipCallLeg - setState()
java.lang.NullPointerException

AACC side has determined to be a CM issue.

Cause

They are using only one trunk group for inbound and outbound calls with 5 T lines 115 members in total.
Status trunk shows all the member are connected to a port 1B1701 and some of them have calls.
All the members were in-service/active connected to 1B1701 which is Music on hold.

001/001 01B0901 in-service/active no 01B1701
0001/002 01B0902 in-service/active no 01B1701
0001/003 01B0903 in-service/active no S01779 S01781
0001/004 01B0904 in-service/active no 01B1701
0001/005 01B0905 in-service/active no 01B1701

After further investigation found out they have several calls in queue but less agents to take calls therefore all the calls in queue listening to music provided on trunks thus maxing out the resources

Solution

Ensure the customer has sufficient trunk groups and each trunk group has sufficient members.

Additional Relevant Phrases

denial event no No circ chan avail SOLN290732

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