Avaya Communicator for Android: VoIP Service Limited is seen after initial registration to Avaya SBCE as a Remote Worker


Doc ID    SOLN290913
Version:    10.0
Status:    Published
Published date:    15 Feb 2021
Created Date:    09 Jun 2016
Author:   
risuaan
 

Details

VOIP Service Limited Error on Avaya Communicator for Android (Avaya Communicator for Android 2.1.4, Avaya SBCE 7.0.1, Avaya SM 6.3.x, Avaya CM 6.3.x)

 

Avaya Equinox Windows - displays red triangle warning "Access to Avaya Equinox contacts currently limited" and "Contact Service is currently unavailable"

Problem Clarification

When Android Avaya Communicator 2.1.4 registers as a Remote Worker to the Avaya SBCE 7.x, a VoIP Service Limited error is seen after initial registration completes.

Problem 2 - VoIP Service Limited for Apple and Android Equinox clients.  Windows clients have no errors.

Cause

PPM was not configured correctly in the Avaya SBCE. Personal Profile Management works through HTTPS protocol and port 443 to send the advanced CM features/capabilites to the endpoint. However, customer configured PPM in SBCE to use HTTP/port 80.

There's another cause of this problem that is the wrong certificate selected for the HTTPS, make sure that the correct certificate is used when you configured the reverse proxy, the server certificate should be the one that was issued by the root authority that you installed the root certificate in the phone.

Cause 2 - EC500 was not properly set up on the Apple and Android Equinox clients

 

In another instance Avaya Equinox Windows was connecting to SBC and issue was only reproducible on internal network.

Solution

Solution Delivered. Corrected PPM settings (Reverse Proxy) in SBCE 7.x of customer and that solve the problem.

Second Solution: Advised Customer to work with network team to ensure required ports are open as per Avaya Equinox Port Matrix document.

Solution 2 - check and fix EC500

Attachment File

EquinoxRLS_PortMatrix-173860.pdf
949K • 3 minute(s) @ 56k, < 1 minute @ broadband


Additional Relevant Phrases

Receiving VoIP Services Limited on Communicator for Android Android phones are not registering properly Customer configured PPM on port 80 and On Equinox we are getting error 2018-07-11 17:13:11.448 D [csdkloop] [CSDK] PPM: SENDING 445 bytes to http://109.63.49.237/axis/services/PPM with Request Timeout equals 10000 { <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"> <soapenv:Body> . But we dont see any messages on SBC on port 80. There was some issue with Firewall and after opening port 80 issue resolved. There is a warning on the IX client that the call history is not being updated when the customer is connected as remote worker, however the call history is there. The issue is with the warning message

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