calls disappear in skill reports


Doc ID    SOLN293615
Version:    3.0
Status:    Published
Published date:    14 Mar 2017
Created Date:    26 Jul 2016
Author:   
Ming Jiang
 

Details

The ACD calls is zero in CMS Skill report at 7:30-8:00.  It became normally after 8:00.

there are maintenance activity on CM (disaster test) at early hours that day.

Problem Clarification

they want to know is the “IGNORED waiting idling event" means. is this related to the abnormal data in the report or not. during interval 7:00-8:00, cms report shows there is no call coming where WFM shows there are call coming.

Cause

From the spi.log.1 you sent, I observe this:

Some trunk e.g. x3d75 is still set to maintenance busy on CMS around the error occurrence time:

> TIME20 TIME 07:31:00 TZ +8:00 yday 205 07/23/16 {UNIX: Sat Jul 23 07:31:01}
Line 686: -> TAUDIT20 MBUSY :51 itn x3d75 size 3 msgseq 122139
Line 2185: -> TAUDIT20 MBUSY :03 itn x3d75 size 3 msgseq 123478
Line 3763: -> TAUDIT20 MBUSY :15 itn x3d75 size 3 msgseq 124858

-> TIME20 TIME 07:39:00 TZ +8:00 yday 205 07/23/16 {UNIX: Sat Jul 23 07:39:00}
-> SETUP22 SEIZED :23 itn x3d75 dir in size 11 msgseq 125898 net 5 seq 667 stamp $h1469230763
# ERROR SEIZED from MBUSY is illegal
<- CPERROR7 ERROR itn x3d75 opcode 254 pos x0
-> DNEVENT20 VDN :23 itn x3d75 iln x107 calls 1 size 15 msgseq 125899 net 5 seq 667 stamp $h1469230763
# IGNORED waiting idling event
-> VSTART20 VSTART :23 itn x3d75 vec 208 size 12 msgseq 125900 net 5 seq 667 stamp $h1469230763
# IGNORED waiting idling event
-> DIGITS20 ANI_SID :23 itn x3d75 digits $13828408293 size 19 msgseq 125901 net 5 seq 667 stamp $h1469230763
-> DFWD23 DFWD :23 itn x3d75 vec 251 ftype 0 ptype 0 prt 0 size 17 msgseq 125902 net 5 seq 667 stamp $h1469230763 {to VDN}
# IGNORED waiting idling event
-> DNEVENT20 VDN :23 itn x3d75 iln x16f size 13 msgseq 125903 net 5 seq 667 stamp $h1469230763
# IGNORED waiting idling event
-> VSTART20 VSTART :23 itn x3d75 vec 251 size 12 msgseq 125904 net 5 seq 667 stamp $h1469230763
# IGNORED waiting idling event
 

Trunk are set to maintenance busy on CMS. thus CMS will not capture the call information.

Solution

-> QUEUED23 QUEUED :38 itn x3d75 sp 126 pri 2 ewt 0 size 18 msgseq 125926 net 5 seq 667 stamp $h1469230763
# IGNORED waiting idling event
-> DCON23 DCON :38 itn x3d75 pos x1329 sk 126 lv 1 pfsk= 0 surp= 2 size 17 msgseq 125927 net 5 seq 667 stamp $h1469230763
Line 5028: -> IDLE23 IDLE :42 itn x3d75 rabort= 0 size 11 msgseq 125932 net 5 seq 667 stamp $h1469230763
# IGNORED waiting idling event
Line 5713: -> TAUDIT20 IDLE :31 itn x3d75 size 3 msgseq 126427
Line 7394: -> TAUDIT20 IDLE :42 itn x3d75 size 3 msgseq 127865
Line 8684: -> TAUDIT20 IDLE :53 itn x3d75 size 3 msgseq 129099
Line 10433: -> TAUDIT20 IDLE :06 itn x3d75 size 3 msgseq 130564
Line 12021: -> TAUDIT20 IDLE :19 itn x3d75 size 3 msgseq 131949
Line 13810: -> TAUDIT20 IDLE :31 itn x3d75 size 3 msgseq 133435

So looks like some trunk status is still set to maintenance busy on CMS side at 7:00 am July 23, thus CMS had ignored message and UCID was not captured for it. After there is a call coming and the call is released, the idle status is correctly updated to CMS, thus later on this issue automatically fixed by itself

Culprit most likely is due to CM operation and maintenance, some trunk status are set to maintenance busy, but when these trunk are released, the updated status are not popped up to CMS side correctly. So CMS will still regard these trunk as maintenance busy and will ignore the call traffic on these lines.

So next time, after CM trunk are set to maintenance busy and released, please manually switch on and off data collection on cms side, this will initialize all CM unit status on CMS again.

Additional Relevant Phrases

can not see the call information of specific day need customer to capture the following logs for investigation var/elog/elog* (elog, elog.01, elog.02 etc) /cms/pbx/acdN/spi.err* (N is the acd having such problem) /cms/pbx/acdN/spi.log* (N is the acd having such problem) /cms/pbx/acdN/xln.log* /cms/dc/archive/arch.log* /cms/dc/harchive/harch.log* /cms/install/logdir/admin.log /var/log/messages*

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