CMS: Can we compare cms call report with echi data


Doc ID    SOLN293693
Version:    4.0
Status:    Published
Published date:    03 Apr 2022
Created Date:    28 Jul 2016
Author:   
Ming Jiang
 

Details

Any CMS Release

Customer found there are number difference with call offered and call answered between CMS report and ECHI data report.

Problem Clarification

Customer want to understand why ECHI CMS value is different from CMS internal call reports

Cause

There is no such thing as ECHI CMS values. ECHI stands for External Call History Interface. This essentially synonymous with the ECH_Handler package that strips data from the call record buffers and creates the binary ECH files (which may be translated to ASCII). So, the process by which ECH is handled and the data in the ECH files are two very different things.

So even if you meant ECH data values, your statement still is unclear because once ECH is activated, there is no longer data stored in the call_recs table, so it would not be possible to compare what is on CMS with what is found in the exported data.

But if the comparison is being made between ECH data and CMS Historical data (agent, skill, vdn, cwc) we have never, and will not provide any support for such comparisons due to the different algorithms involved in formulating the two different sets of data. We expect that the data will not crossfoot and therefore we will not get involved in trying to resolve the differences. That is basically our policy

Solution

When voice contact activity occurs in the Avaya PBX, every discrete action performed by the
switch generates an event stream which is then sent as binary data to the CMS. Within CMS
there is a series of Switch Protocol Interpreter (SPI) processes which translate this data. The data
is then available for either real-time or historical reporting. While real-time reporting is beyond the
scope of this document, there is a SPI process stream that uses the binary data from the PBX to
create the ECH data records. This is a different SPI process stream than is used to create the
historical data such as agent, skill, vdn, trunk and vector data that is used by CMS Supervisor
reports. Since historical data and ECH data are distinct interpretations of the binary data, and
because the fundamental purpose of ECH is different than the historical data, there is never any
guarantee that metric totals from the historical data will match the totals from ECH and vice versa


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