VP/AAEP : Web service call timeout reported and application flow is interrupted throwing bad fetch for web -service call.


Doc ID    SOLN293991
Version:    1.0
Status:    Published
Published date:    02 Aug 2016
Author:   
Sandeep ParvathReddy
 

Details


VP 5.1 Sp1

Applicable for all  VP and AAEP versions.

Problem Clarification

The web service request was timing out

Cause

The fetch timeout on the application for the web service was set to 3 seconds and the response to the web service call was taking more than 3 seconds which was causing the issue.

Solution

The 3 seconds timeout should be fetchtimeout defined in the page where it invokes the web service or in global setting of their application.  This is from OD online help to define fetchtimeout:

 An example of using an External Property item can be described in the usage of the VoiceXML property fetchtimeout as an External Property item. In this case, the voice browser (AAS) waits a given amount of time (that is, the fetch timeout time) to get a page response back from the application. This timeout is configurable on the platform and applies to all fetches done for all applications. Some applications can exceed this timeout during long operations. Such operations can be database access, an AES dial operation that has a long ring timeout, Web service calls.
Instead of changing the platform timeout, set the fetchtimeout property in a node or in the AppRoot (for an application-wide change) and change the timeout to a more appropriate value. For example, set Name to fetchtimeout and value to 30 seconds (15 seconds more than the default timeout).
Note:
A very long fetchtimeout can have a negative effect on the efficiency of the browser in cases where the application has a catastrophic error and the browser is waiting for a page response or exceeding the timeout.
 
  The default fetchtimeout on EP platform is 15 seconds.

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