CM: Intermittent SIP call drops, getting message 500 Server Link Monitor Status Down


Doc ID    SOLN294050
Version:    4.0
Status:    Published
Published date:    23 Apr 2020
Created Date:    02 Aug 2016
Author:   
Bibin Mathew
 

Details

Intermittently calls are getting dropped and not going through. Getting message "500 Server Internal Error".

This is applicable to all CM versions.
Call flow - Frequently Outbound dialer making call > CM > SM > Service provider.

Below the SIP messages for a failed call.

------------------------------------------------------------------------------------------------------------------------------------------------------------------------
        192.168.xx.xx           192.168.xx.xx
                  *192.168.xx.xx*
------------------------------------------------------------------------------------------------------------------------------------------------------------------------
12:29:42.648 |--INVITE-->|           | (186) sip:[email protected] U:91314xxx506
12:29:42.649 |<--Trying--|           | (186) 100 Trying
12:29:42.654 |           |--INVITE-->| (187) T:13148xxxx06 F:88xxxx3607 U:1314xxxx506
12:29:42.670 |           |<--Trying--| (187) 100 Trying
12:29:42.671 |           |<--Server -| (187) 500 Server Link Monitor Status Down
12:29:42.671 |           |----ACK--->| (187) sip:[email protected]
12:29:42.672 |<--Server -|           | (186) 500 Server Internal Error
12:29:42.682 |----ACK--->|           | (186) sip:[email protected]
 

The dialer makes a call and reaches CM which is then forwarded to SM and to the service provider. From the trace, it can be seen that the CM received a "500 Server Link Monitor Status Down" message from the SM. By taking an indepth look into the SM logs, it was found that the SM was actually sending all the necessary messages to the far end (in this case it is the service provider, there was no SBC in customer environment), but the far end was not responding. The service provider claimed that they didn't receive any messages for the calls, but later it was found to be issue with one of the SBCs with the service provider.

Problem Clarification

SIP calls getting dropped even before connecting with the callee. Customer has to make multiple attempts to make a successful call.

Cause

Issue has been found with the service provider. Calls going out through their primary SBC were not getting completed.

Solution

After calls were sent through service provider's secondary SBC, no more call drops reported. Issue was with the primary SBC of the service provider.

Additional Relevant Phrases

500 Server Link Monitor status down” being sent by Session Manager to SBCE for outbound calls Outbound calls fail for 3 to 5 minutes with call flow (ACME->Session Manager ->Communication Manager) cannot make outbound calls due to server link monitor status down.

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