Forwarded calls get disconnected while ringing


Doc ID    SOLN294070
Version:    1.0
Status:    Published
Published date:    03 Aug 2016
Author:   
Ying Sun
 

Details

Forwarded calls get disconnected while riging
Recent Migration on CM6Forwarded calls get disconnected while rigingNone

Problem Clarification

SBC cannot get the resource during the from the trace log

Cause

the second SDP, it didn’t provide the connection IP, which means the tone source was missed from Service Provider

we got the SIP 18x with SDP message, which means the tone source is provided by the service provider side. And for the split ring issue, we found from SP to SPC. The first 183 message from SP to SBC provided the tone source which is good and can be shown below:
 
IP:0xca0a0489:5060 --> 0xaf5c72e:5060
[07-13-2016:14.14.17.633198] DBG#SIP MSG AT CALL CONTROL IN:
SIP/2.0 183 Session Description
From: "Comlinx Test" <sip:[email protected]>;tag=0d0afba654e616b405773f27600
To: <sip:[email protected]>;tag=88296
CSeq: 1 INVITE
Call-ID: 6838954aee651216d07635070295d658
Supported: com.nortelnetworks.firewall,p-3rdpartycontrol,nosec,join,x-nortel-sipvc,gin
User-Agent: Nortel SESM 14.1.10.0
Via: SIP/2.0/UDP 10.245.199.46:5060;branch=z9hG4bK-s1632-002090649811-1--s1632-
Content-Type: application/sdp
Content-Length: 210
 
v=0
o=IWSPM 521443800 521443800 IN IP4 202.10.4.137
s=-
c=IN IP4 202.10.4.137
t=0 0
m=audio 53794 RTP/AVP 8 127
a=rtpmap:8 PCMA/8000
a=rtpmap:127 telephone-event/8000
a=ptime:20
 
But the second SDP, it didn’t provide the connection IP, which means the tone source was missed from Service Provider.
 
IP:0xac110421:5060 --> 0xac11040e:33056
[07-13-2016:14.14.21.925730] DBG#SIP MSG AT CALL CONTROL IN:
SIP/2.0 183 Session Description
From: "Comlinx Test" <sip:[email protected]>;tag=0d0afba654e616b405773f27600
To: <sip:[email protected]>;tag=88296
CSeq: 1 INVITE
Call-ID: 6838954aee651216d07635070295d658
Supported: com.nortelnetworks.firewall,p-3rdpartycontrol,nosec,join,x-nortel-sipvc,gin
User-Agent: Nortel SESM 14.1.10.0
Via: SIP/2.0/UDP 10.245.199.46:5060;branch=z9hG4bK-s1632-002090649811-1--s1632-
Content-Type: application/sdp
Content-Length: 217
 
v=0
o=IWSPM 521443800 521443801 IN IP4 202.10.4.137
s=-
c=IN IP4 0.0.0.0
t=0 0
m=audio 53794 RTP/AVP 8 127
a=rtpmap:8 PCMA/8000
a=rtpmap:127 telephone-event/8000
a=ptime:20
a=sendonly
 
In this case we still think you need to check with Service Provider side why they send the connection IP as 0.0.0.0 back to SPC. Normally, it’s a hold behavior.

Solution

need to check on ISP


Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy