CM: cannot restore backup translation to CM system


Doc ID    SOLN295215
Version:    4.0
Status:    Published
Published date:    19 Mar 2022
Created Date:    22 Aug 2016
Author:   
Bin Liu
 

Details

Failed to restore backup translation file to cm system.
This has occurred in various versions (ex. 6.3 sp10 and CM 7.1 SP2 VMware)

Problem Clarification

After restoring the CM translation files, there is no data and nothing displayed using list configure. Also seen as a valid translation, but creating incorrect/missing settings on startup.

Cause

The restore steps are fine, and no errors are found in the logs. However, when successfully to complete all the steps, we check the cm system /etc/opt/defty/xln1 file, and find the generated date/time is some days ago, and is not current. This incorrect file would cause the CM system to fail to use the translation file. 

Solution

We can manual copy the backup-translation xln file to cm system to overrite the original xln file, then do reset system 4. After that, all the data of backup shows up normally. 

Seems like the issue may be from the first installation of the cm system but the cause is not clear. Currently all are working fine after manual data restore.


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