CM: MWI is not working on extensions when DuVoice messaging system tries to use LWC feature-access code


Doc ID    SOLN295950
Version:    1.0
Status:    Published
Published date:    30 Nov 2016
Author:   
arvizu
 

Details

MWI not working on CM extensions using LWC fac within an incoming invite from DuVoice
CM 6.3
SM 6.3
3rd party analog / digital phones
Messaging system is DuVoice DV2000

Problem Clarification

MWI is not working on the phones.
DuVoice sends an invite message with FAC (Leave Word Calling Send A Message) and extension number to light the lamps on, so the invite coming in the sip trunk looks like:

INVITE sip:*[email protected] SIP/2.0

Where:

*63 is theLeave Word Calling Send A Message FAC
7201 is the extension number


I tried using Avaya One-X communicator softphone as extension and the same situation, so this told me the phones are not the issue.

Cause

LWC is a station feature so in some way a station has to be associated with activating the feature which means the feature can not be used as bp is expecting.

Solution

CM is working as designed as LWC is a station feature, in this case the only available solution is to use NOTIFY method which means the Duvoice system will send a NOTIFY sip message to light the lamps on.

Additional information can be found in the following interoperability document


https://www.devconnectprogram.com/fileMedia/download/8298cf89-24b2-4200-b6fd-ed2f17c2d0d3


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