CM with CIE: Redirect on no answer isnt working.


Doc ID    SOLN298229
Version:    2.0
Status:    Published
Published date:    29 May 2018
Created Date:    14 Oct 2016
Author:   
Andras Varga
 

Details

CM 7.0.1 via Customer Interaction Express connection via SIP trunk

Problem Clarification

Scenario:
CIE is an callcenter-application which adjuncts to CM via SIP-trunks.
CIE gets call via the SIP-trunk and in condition agent is free, CIE transfers the call to an extension.
As there is no free agent-station, caller gets announcement from CIE and is transfered to station as soon as agent becomes available.

As if agent doesn´t answer the call, CIE deflects call back to CIE-trunk.

Error:
As if agent is free while call arrives at CIE, CIE deflects call to agent station (without connect/transfer).
In this case, CIE isn´t able to “recall” the call (defect again to CIE-trunk).

CM answers ty with CS0/98 “Message Incompat with Call State” (which maps to CSTA error 22 on TSAPI: INVALID_OBJECT_STATE).


As if there is no free agent, call gets queue/announced in CIE and transfered to agent as soon as Agent becomes available,
CIE CAN deflect call back to CIE-trunk.

Cause

CM configuration issue

Solution

Modified the vector:
from
route-to number V1 with cov N
to
route-to number V1 with cov Y


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