Call forward fails from some hard phones


Doc ID    SOLN304004
Version:    1.0
Status:    Published
Published date:    01 Feb 2017
Author:   
Guest User
 

Details

Call forward fails from some hard phones. Call is forwarded. Called number
is answered at the forwarded destination. Answered call has no talk path.
Caller continues to hear ring back after answered.

Problem Clarification

Site is using the call forward button on the hard phones to forward calls and they are failing. The issue is only specific to when the site uses simring (multiple users loggin) and the phones is forwarded to a PSTN number (cell Phone) via the cfw button on the phone. In this case the call is routed out via the MG3k. The same call scenario works fine if the site sets up the call forwarding & simring via the PA

Cause

After log analysis we have determined the cause of this issue:
during simring call AS5300 forwards only one 18x provisional response to the originator. Other 18x provisional requests will not pass to the originator. As AudioCodes generates 183 Session progress response with "Require: 100rel" header it waits for PRACK to be generated by the originator. As AudioCodes doesn't receive PRACK it doesn't send 200 OK response.
In such scenario AS 5300 should pass 18x Session Progress response to the originator for successful session establishing.

Solution

There is workaround for this. On AudioCodes it's necessary to disable Early 183 and turn disable Prack.
(Configuration->Voip->SIP Definitions->Advanced Parameters->Early 183 and Configuration->Voip->SIP Definitions->General Parameters->Prack Mode).


Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy