ONEXAGENT: One-X Agent (H.323) RAS Registration Clarification in NAT'ed environment


Doc ID    SOLN305818
Version:    2.0
Status:    Published
Published date:    16 Jan 2018
Created Date:    03 Mar 2017
Author:   
Khan Khoda
 

Details

One-X Agent (All Release) Avaya Communication Manager (All Release) Refer to the Client's "Proof of Concept" topology diagram "PoCC_1XA_Diagram_KK.jpg" as reference in the attachment section.

Problem Clarification

This investigation was part of a client's “Proof of Concept” project. We were investigating the scenario where Avaya One-X Agent soft client using H.323 protocol and in Road Warrior/ Computer Mode, in a home environment, without VPN connectivity (I.e from public domain) attempting to register to Communication Manager, which is located in Data Center environment behind the NAT. One-X Agent (H.323) was not able to register to CM. Refer to the Client's "Proof of Concept" topology diagram "PoCC_1XA_Diagram_KKv2.jpg" as reference in the attachment section. This KB is a follow-up to the internal KB article “SOLN268012”. This KB indicates that there were some changes developed in Avaya One-X 2.5.5 from One-x Agent V 2.5.2 and PSN004547u was published. We also needed to clarify "NAT support" for One-X Agent 2.5.8. As per the release notes (https://downloads.avaya.com/css/P8/documents/101013917), we reached out to ONEXAGENT Product House.

Cause

Working as designed. Based on the topology diagram and NAT'ed environment explained in attached document. When Communication Manager is behind NAT'ed environment, One-X Agent (H.323) will not be able to registered. With ONE-X Agent GA release 2.5.8, Avaya has made changes to one-X Agent to work behind NAT (only and NOT NAPT) in “My Computer” mode which was having issues while working through a Firewall. So the registry keys mentioned in 1XA 2.5.8 release note supposed to work in the configuration where the one-X Agent is behind NAT and being used in “My Computer” mode.

 

One-X Agent 2.5.8 onwards H323 does support NAT but not NAPT:

 

https://downloads.avaya.com/css/P8/documents/101036922

 

Page 9

Solution

Clarification Summary Received from ONEXAGENT Product House Team: - 1xA does NOT work where the CM is behind NAT so the client configuration will not work? – [PRODUCT HOUSE] – Correct\True. - There were changes made to 1xA (2.5.8 Release and above) to work behind NAT in “my computer” mode which does work and which could be recommended to the scenario where Communication Manager is behind NAT as a solution/mitigation to their problem? – [PRODUCT HOUSE] Yes, but above condition must be satisfied (i.e. CM should be in public space and not in private network).


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