SMGR: CM notify sync feature


Doc ID    SOLN305901
Version:    4.0
Status:    Published
Published date:    18 Dec 2023
Created Date:    06 Mar 2017
Author:   
Kiran Gowda
 

Details

CM notify information
 

one way CM notify sync feature

Two way CM notify sync feature

Problem Clarification

CM notify information

Cause

CM notify information

Solution

Overview of the CM notify sync feature:

 
When you perform an administrative task from System Manager, the local database is immediately updated. If you execute the action through a Communication Manager SAT screen, or through a
phone, or from any of the several management applications such as Site Administration, MultiSite Administration, Native Configuration Manager, or MyPhone, it is not immediately reflected in System
Manager. This scenario creates an out-of-sync condition between the Communication Manager andSystem Manager.
 
 
The CM notify sync feature provides near-real time notifications from Communication Manager to System Manager whenever you execute certain tasks against a Communication Manager object
from a system other than System Manager. The CM notify sync feature also provides notifications whenever the tti-m, tti-s, psa-u, psa-a, or psa-d logins perform their predefined actions against a
Communication Manager station object.
 
After a Communication Manager sends notifications to System Manager, System Manager discovers the complete details of the task you preformed. The transmission of notifications in the
form of event messages from Communication Manager to System Manager is based on the Communication Manager’s existing rsyslog capability. The Communication Manager’s rsyslog uses
UDP or TCP to send event messages from the originating Communication Manager to the System Manager.
 
 
Note:
The existing daily default synchronization and any other scheduled synchronization operations are unaffected by the CM notify sync feature.
You need Communication Manager with version 6.2 or above for to enable the CM notify sync feature. System Manager 6.3 supports both one-way and two-way TLS.
 
Enabling the CM notify sync feature :
You can enable and disable the CM notify sync feature on a per Communication Manager basis.
You can activate the CM notify sync feature from a new System Manager using Manage Elements. Select Communication Manager 6.2 or a higher version, and select Enable Notifications in the
Attributes section. As a system administrator, you must specify the IPs of one or two System Managers to which the
Communication Managers send the event data using rsyslog. If your configuration includes two System Managers, the standby System Manager ignores the syslog messages until it becomes
active.
 
You can have one-way and two-way TLS.

https://downloads.avaya.com/css/P8/documents/100182973

Please follow above link for how to activate this feature. Page No 1184.

Additional Relevant Phrases

Enable notifications feature is not working for SAT updates on the communication manager. I verified the feature is enabled and logging is functional per help docs, but the updates to System cm SYNC FAILURE (CM) 10.1.x Avaya has identified an issue after installation of Security Service Pack (SSP) 7 through 11 where the following behavior may be observed: • Nothing is written to /var/log/messages. • Nothing is written to /var/log/ecs/commandhistory. • If configured, the notify sync feature in Avaya Aura System Manager (SMGR) will stop work Avaya strongly recommends updating to SSP #12 or later to resolve the issue.

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