SMGR:Virtual Machine Resources Reservation shows warning.


Doc ID    SOLN306674
Version:    4.0
Status:    Published
Published date:    05 Mar 2024
Created Date:    20 Mar 2017
Author:   
Kiran Gowda
 

Details

 CPU warning in our system manager

Customer saw sudden hike in  high disk usage on System manager OS. Unable to clear log file.

Problem Clarification

Customer was reported with SMGR Resource set to zero.

Cause

 

root >sh /opt/vsp/VMWrapper/checkVMReservation.sh
 
Thu Mar  9 10:59:09 CST 2017 : Virtual Machine Resources Reservation Details:-
 
.-------------------------------------------------------------------.
 
|               Virtual Machine Resources Reservation               |
 
+-------------+---------------------+----------------------+--------+
 
|  Resources  | Current Reservation | Required Reservation | Status |
 
+-------------+---------------------+----------------------+--------+
 
|  vCPU (MHz) |          0          |          9160        |  Fail  |
 
| Memory (MB) |          0          |          9216        |  Fail  |
 
'-------------+---------------------+----------------------+--------'
 
  << Invalid Virtual Machine resource reservation >>
 

Solution

Worked with customer to check on CPU overload. Have provided document and aswered all queries.
 

 

  =========================================================================
=========================================================================
AV:Test: skel_vmwarerescpu  -> (Parent:runtests) -> (Parent:skel_runtests)
System Info: IP:10.2.51.57, Hostname:ndcsysmgr.int.asurion.com (root), Hardware:VMware, Inc./VMware Virtual Platform
Date: Thu Mar  9 06:09:06 CST 2017
 
It is wise to reserve CPU cores for each VM.  If this is set to 0, then
VMware did not put any CPU cores aside to reserve it.  There is no guarantee
that the VMware host can provide the correct amount of CPU cycles when the OS
demands it.
 
This can only be fixed on the host side, which is beyond the scope of
Avaya's involvement.
 
Currently the Avaya VM OVAs by default all have reservations.
Many customers set the reservations to 0.
Collaboration Pod install docs instruct to turn off all reservations (set them to 0).
We currently have this test responding at a WARN level as it is something to take note of, but not something that MUST be remedied.
 
# vmware-toolbox-cmd stat cpures
0 MHz
 
AV: author:mweller modified:20141204 fixed bug in output of oneline summary
Category: vmware
 
 
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 
=========================================================================
=========================================================================
AV:Test: skel_vmwareresmem  -> (Parent:runtests) -> (Parent:skel_runtests)
System Info: IP:10.2.51.57, Hostname:ndcsysmgr.int.asurion.com (root), Hardware:VMware, Inc./VMware Virtual Platform
Date: Thu Mar  9 06:09:06 CST 2017
 
It is wise to reserve memory for each VM.  If this is set to 0, then
VMware did not put the memory aside to reserve it.  There is no guarantee
that the VMware host can provide the correct amount of RAM when the OS
demands it.
 
This can only be fixed on the host side, which is beyond the scope of
Avaya's involvement.
 
Currently the Avaya VM OVAs by default all have reservations.
Many customers set the reservations to 0.
Collaboration Pod install docs instruct to turn off all reservations (set them to 0).
We currently have this test responding at a WARN level as it is something to take note of, but not something that MUST be remedied.
 
# vmware-toolbox-cmd stat memres
0 MB
 
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 
Set the reservations correctly and restart the VM, then check the CPU after some time

Additional Relevant Phrases

SMGR Admin user password incorrect

Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy