AACC: Agents Get Logged Out of AAAD/CCMM every 30 minutes


Doc ID    SOLN307659
Version:    2.0
Status:    Published
Published date:    20 Apr 2017
Created Date:    06 Apr 2017
Author:   
Deshandise Jones
 

Details

 AACC HA 6.4 SP15 CCMM HA separate server VM

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AAAD Log

017-04-05 16:40:52.267 +02:00 CCAD MainForm 27 16064 Major None Ping returned an error. Number of consecutive failures = 1

2017-04-05 16:40:53.757 +02:00 CCAD MainForm 26 0 Debug None LinkStateChange() _session.ToolkitStatus:ConnectedNoStandby, e.LinkID: Primary, e.State.Code:Connecting

2017-04-05 16:40:53.757 +02:00 CCAD MainForm 26 0 Debug None Connecting to Primary server 155.235.79.xxx...

2017-04-05 16:40:54.737 +02:00 CCAD MainForm 1 0 Debug None Entering StatsRefresh()

2017-04-05 16:40:54.787 +02:00 CCAD MainForm 23 0 Debug None LinkStateChange() _session.ToolkitStatus:ConnectedNoStandby, e.LinkID: Primary, e.State.Code:ConnectionFailed

2017-04-05 16:40:54.787 +02:00 CCAD MainForm 23 0 Debug None Failed to connect to Primary server 155.235.79.xxx (Unreachable).

2017-04-05 16:40:59.917 +02:00 CCAD MainForm 1 0 Debug None HideStatusMessage(): On GUI thread, clear status bar message.

2017-04-05 16:41:00.767 +02:00 CommunicationLayer 40 15120 Crit None Error (Web Exception) retrieving data from Web Service ReadCustomer

 

EXCEPTION: 

System.Net.WebException: The operation has timed out at System.Web.Services.Protocols.WebClientProtocol.GetWebResponse(WebRequest request) at System.Web.Services.Protocols.HttpWebClientProtocol.GetWebResponse(WebRequest request)

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CCT_Server Log

2017-04-05 16:40:47.599 CCTSERVER 4-20328 0 Major None Error Factory A CCT session aborted due to a CommunicationException: The socket connection was aborted. This could be caused by an error processing your message or a receive timeout being exceeded by the remote host, or an underlying network resource issue. Local socket timeout was '10675199.02:48:05.4775807'.

 

InnerException -> System.IO.IOException: The read operation failed, see inner exception.

 

InnerException -> System.ServiceModel.CommunicationException: The socket connection was aborted. This could be caused by an error processing your message or a receive timeout being exceeded by the remote host, or an underlying network resource issue. Local socket timeout was '10675199.02:48:05.4775807'.

 

InnerException -> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host

 

2017-04-05 16:40:47.601 CCTSERVER 10-17516 (CMF-1) 0 Debug None EvntIn AgentAddress sip:[email protected] Address Property Event - Property: State(Enable(CTILinkUp)), Caps=[Originate | Transfer | Conference | Consult | BargeIn | Observe | GetAcquireStatus | SetAcquireStatus] - IGNORED(StateEventGenerated)

2017-04-05 16:41:15.874 CCTSERVER 7-13356 0 Debug None CallIn Agent 27005/Session 469 (LINDE\ZA04ED) Logout()

2017-04-05 16:41:15.874 CCTSERVER 7-13356 0 Debug None CallOut User 27005 User.Logout()

2017-04-05 16:41:15.892 CCTSERVER 7-13356 0 Debug None CallOut User 27005 User.Logout - Result: 

2017-04-05 16:41:15.892 CCTSERVER 7-13356 0 Debug None CallIn Agent 27005/Session 469 (LINDE\ZA04ED) Logout - Result:

Problem Clarification

"AAAD agents disconnected from CCMM"

Cause

Customer Network issue identified VLAN flapping (VLAN the AACC was connected to was flapping)

Solution

Customer resolved their network issue causing the VLAN flapping, system stablized.


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