[APS product] [AgentMap4.1.2.6] AgentMap client cannot login.


Doc ID    SOLN308529
Version:    1.0
Status:    Published
Published date:    27 Apr 2017
Author:   
kyoshitake
 

Details

Simple Description: Wrong setting of Agentmap client [MessagePort] will occupy server ports gradually.

Please see following about detail.

One day, users said "Login screen does not appear, and cannot login to Agentmap client.". This issue happened at multiple users at same timing.

Problem Clarification

In Agentmap server side, windows 2003 server had recorded "Invalid packet data. Shutting down the connection" in the event log (application). This event log message has been generated by Agentmap server application. And, it included information about IP address and port number for connection.

Target PC had repeated connection request every minutes using different port number, so we can see a lot of errors in event log.

After investigation, we found user had changed [MessagePort] setting to incorrect number "5378". He had misunderstood as that [MessagePort] number should be same to [AgentMAP Client]. 

Following is good setting sample of our lab. Each port should be different.

C:\Users\[windows userID]\AppData\Roaming\Avaya\Agent MAP Client

[AgentMAP Client]
IP_Address=0.0.0.0
PortNo=5378
Interval=3
CacheExp=30
Extension=
IP_Address1=135.27.xxx.xxx
PortNo1=5378
MessagePortNo1=5381  <<<  Never set to 5378!

Cause

Improper setting of Agentmap client side.

Solution

1) If you found this error occurred, unplug network cable immediately from target PC. You can see this error in eventlog of Agentmap server side, but no error was recorded to client PC side.
If you want to see it by Agentmap log, please enable Agentmap log option.(It needs service restart of Agentmap.)

2) If there is no available port in Agentmap server side, you need to restart Agentmap server service from management tool menu.

3) Then, confirm Environment.ini in target client PC.
You can see Environment.ini in each windows users profile. So please confirm windows user ID beforehand.

Port number should be incorrect.


[Note]
This error message has been applied from Agentmap 4.1.2.6.
If you are using 4.1.2.0, and got invalid packet from PC, your Agentmap server generated huge size log, and Agentmap server service would down immediately.
Unless you remove target PC from network, agentmap server service cannot starts up again.

Additional Relevant Phrases

Agentmap APS windows netstat

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