Avaya Equinox for Windows: No ringback when SM SIP extensions are calling Cs1k IP phones


Doc ID    SOLN308543
Version:    5.0
Status:    Published
Published date:    09 Apr 2018
Created Date:    25 Apr 2017
Author:   
Yugesh Kolli
 

Details

Avaya Aura 7

Equinox 3.0.0.147

 

Problem Clarification

When a SM SIP User is calling Cs1k IP phone there is no ringback tone. However call connects fine when the  user at Cs1K IP phone answers the call or when the call routes to call pilot via coverage

Cause

After the tracing and testing sessions,  it was found that Issue is with Equinox client itself, as we did not observe the issue with Old client AVAYA Communicator.

 

Logs found from Equinox client  in bad case:

2017-02-03 14:43:39.915 [INFO] - [CSDK] [Native thread: 13344]: CWebRTCAudioEngine[0x138CC9C0]::StartPlayingFileInChannel  : file:'ringback.wav' channelId:0 loop:1 durationMs:0 gain:255 speaker: 1 callback:1

2017-02-03 14:43:39.915 [ERROR] - [CSDK] [Native thread: 13940]: ERROR     ; ( 9:13:39:854 |    0)         FILE:    2  1025;     13344; Could not open input file C:\Program Files (x86)\Avaya\Avaya Equinox\Resources\Audio/ringback.wav

2017-02-03 14:43:39.915 [WARNING] - [CSDK] [Native thread: 13940]: WARNING   ; ( 9:13:39:854 |    0)        VOICE:    2  1025;     13344; FilePlayerImpl::StartPlayingFile() failed to initialize file C:\Program Files (x86)\Avaya\Avaya Equinox\Resources\Audio/ringback.wav playout.

2017-02-03 14:43:39.915 [ERROR] - [CSDK] [Native thread: 13940]: ERROR     ; ( 9:13:39:855 |    1)        VOICE:    2    99;     13344; StartPlayingFile() failed to start file playout, error = 10016

2017-02-03 14:43:39.915 [ERROR] - [CSDK] [Native thread: 13344]: CWebRTCAudioEngine[0x138CC9C0]::StartPlayingFileInChannel  : StartPlayingFileLocally[ FAIL ] [-1], hPlayback: 3145777, line = 2241

2017-02-03 14:43:39.915 [WARNING] - [CSDK] [Native thread: 13940]: WARNING   ; ( 9:13:39:855 |    0)         FILE:    2  1025;     13344; playing is not active!

 

       2017-02-03 16:12:42.502 [INFO] - [CSDK] [Native thread:  8860]: CWebRTCAudioEngine::CreateFilePlayCall  : Started!

2017-02-03 16:12:42.502 [INFO] - [CSDK] [Native thread:  8860]: CWebRTCAudioEngine::StartPlayingFileInChannel  : file:'ringback.wav' channelId:0 loop:1 durationMs:0 gain:255 speaker: 1 callback:1

2017-02-03 16:12:42.502 [INFO] - [CSDK] [Native thread:  8860]: CWebRTCAudioEngine::RegisterFilePlayInfo  : hPlayback: 197633, Channel: 0, Loop: 1, DurationMs: 0, Gain: 255, Speaker: 1, callback: 1, line: 1731

2017-02-03 16:12:42.502 [INFO] - [CSDK] [Native thread:  8860]: CWebRTCAudioEngine::StartPlayingFileInChannel  : StartPlayingFileLocally, hPlayback: 197633

 

SIP/2.0 480 Temporarily Unavailable

P-Location:

 

Solution

This was Equinox client bug and it is fixed in latest Avaya Equinox for Windows 3.3.1 release.

Attachment Description

Attached is the .dll fix that need to be Copy and Replace in AVAYA Equinox Installation Directory.

Please note that this .dll is only compatible for Equinox version 3.0.0.147

 

Attachment File

AvayaClientServices.dll
35.6MB • 1.76 hours(s) @ 56k, 4 minute(s) @ broadband



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