CM 6.3: Hex UUI from Genesys IVR not being recognized by EMC, which requires Ascii


Doc ID    SOLN310079
Version:    2.0
Status:    Published
Published date:    14 Jun 2018
Created Date:    23 May 2017
Author:   
Arif Neemuchwala
 

Details

IVR is sending calls to CM with UUI and CM sees UUI, but when call gets to EMC it doesn't show UUI. I have validated with the TSAPI exerciser that UUI is there but EMC is not accepting it. Guessing the issue has to do with how UUI is being encoded. Need to see what can be done on EMC side to see UUI.
call flow: I3-IVR(genesys)->CM->aes->Avaya Elite EMC

Problem Clarification

Traces from CM and config checks in system parameters, showd that the
UUI was being passed in Hex correctly.

Cause

uui configuration issue

Solution

Customer  changed the protocol descriptor at the i3 ivr--from 03 to 04-- at the IVR and then the EMC recognized the UUI.

Additional Relevant Phrases

ascii, hex, i3 genesis, EMC

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