SAL GW: The Current Operation Failed, Please See The Debug Log For The Details of Exception


Doc ID    SOLN310427
Version:    4.0
Status:    Published
Published date:    08 Jul 2021
Created Date:    31 May 2017
Author:   
Mark Hunter
 

Details

SAL all versions

Problem Clarification

Receive the following error in the User Interface of the SAL Gateway, "The current operation failed, please see the debug log for the details of exception."

Cause

The xgDeployConfig.xml file was not owned by saluser as well as the /opt/avaya/SAL/gateway/GatewayUI/config/messages.xml file was empty.

Solution

Login to the SAL Gateway with root access and navigate to the /opt/avaya/sal/gateway/Gateway directory and change ownership of the xgDeployConfig.xml file to saluser:saluser by using the following command:

chown saluser:saluser xgDeployConfig.xml

Then rebuild the messages.xml file using one from a backup or one from another working SAL Gateway.


Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy