Experience Portal: Nuance : Nuance Recognizer 10.2.7 Cache SWIres oversized


Doc ID    SOLN310630
Version:    1.0
Status:    Published
Published date:    05 Jun 2017
Author:   
Haseeb Rehman
 

Details

Nuance Recognizer 10.2.7
 

Windows 2012 server

AAEP Experience Portal 7.0  

Problem Clarification

Nuance Recognizer 10.2.7 and SWIrec Cache files
Windows 2012 servers running Nuance Recognizer 10.2.7 is filling up the C drive with cache files

After upgrade to Recognizer 10 in August 2016the issue started with the upgrade but only detected now

Cause

Customer believe the issue started with the upgrade to Nuance 10.2.7.

Solution

Nuance Recommendations:


The answers to the questions:

1) Can we delete these to free up space

As these are cache files, if Nuance services are stopped and not running, you can delete any/all of them.

If Nuance services are running, you should take care not to delete anything dated more recent than the latest startup time, or anything contained in a sub-folder corresponding to any actively running Nuance process PID.

2) what should be managing this to prevent the problem in the future?

Actually this is an old bug which has had several fixes over the years. In NSS 6.2.7 one such bug was fixed, but you are on NSS 6.2.8 - however, there was one more cache cleanup bug fixed in NSS 6.2.10 please review the release notes.

So, the short term solution is to manually clean up the older cache content when the speech services are down for maintenance, or if done during live operations, then carefully only the cache files that are older than the latest speech services start time.

The long term solution is to upgrade to NSS 6.2.10+


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