[IPO] Phone ring once but call is not disconnected and so it will ring the phone again.


Doc ID    SOLN310851
Version:    2.0
Status:    Published
Published date:    21 Sep 2017
Created Date:    08 Jun 2017
Author:   
pcanonce
 

Problem Clarification

When IPO Phone / reception is being called (from external / PSTN) it will ring once and then stop and then ring again.   The expectation is for that phone to ring continuously until answered.

When this happen the screen on the phone will also go blank.   It's like ring / with phone display and then silence / no phone display and then ring / with phone display again.   It seems that after 1 ring the call is getting disconnected BUT in reality the call (on the trunk line) remained connected and it will ring the phone again.

We are sure that this is the same call because we were able to replicate this and we made the test call ourselves. On the PSTN caller end the ringback is continuous.

Cause

This is caused by the setting on LINE > RING OFF MAX.

Here's how the logs looked like.
2017-05-19T14:04:21 1143955750mS ATMChannel: [1] Sloppy timeout(4000ms)
2017-05-19T14:04:21 1143955750mS ATMIO: [1] TRUNK RELEASE
2017-05-19T14:04:21 1143955750mS ATMChannel: [1] StateChange Incoming->Idle

The first line with "Sloppy timeout" matched the current setting on customer's config.    At this point, I am not sure what this TRUNK RELEASE meant and who send this.   However, I am sure that the call is NOT disconnected on the trunk level.

Solution

Initially it was set to 4000ms and so we set it to max 25500ms.
Issue resolved.

Setting the System locale changes this setting. Make sure to set the locale according to the country/region IP Office is installed in.

 

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