WFO: Implication of Removing Record Merge Activity


Doc ID    SOLN311187
Version:    1.0
Status:    Published
Published date:    16 Jun 2017
Author:   
Imaobong Ekwere
 

Details

WFO 12.0 HFR 9

remove the RECORDS MERGE option from wfo
Need to know the impact of removing/deleting Record Merge Activity from WFO application

Problem Clarification

Need to know the impact of removing/deleting Record Merge Activity from WFO application.

The need was due to the fact that when agents went on Lunch, the WFO flagged them with the 'Record Merge Activity'.

Cause


The need was due to the fact that when agents went on Lunch, the WFO flagged them with the 'Record Merge Activity'.

The 'Record Merge Activity' was shown when agents went on lunch because they do not have a 'Lunch' reason code and so agents resort to log out and log in during Lunch which is during the Shift Hours.

Solution

It is not recommended to completely remove Records Merge from the WFO application.

Records merge is an automatic event that is triggered and its meaning is literal because the application is having to merge more than 1 record. A record consists of 1 login and 1 logout, and so if you have more than one of them for the same agent in the same “day”, then it will merge them together to make one. Removing the activity name doesn’t do anything because there will still be a records merge from the system shown in the day details regardless, but the activity needs to be mapped so that it can be easy to manipulate the adherence as the business sees fit.

If you want to stop records merge from occurring, then you have to stop having agents log out during their shifts and only use logout features when you truly expect a logout event to occur and when you do not expect the agent to log back in.

Login + logout = 1 record
So if you have 2 sets of logins and logouts, then that is 2 records. The system will merge them since they are occurring in the say day and at the same shift.


Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy