Policy Server is unable to send email notification


Doc ID    SOLN312428
Version:    1.0
Status:    Published
Published date:    24 Jul 2017
Author:   
Lingxiao Wang
 

Details

policy server is unable to send email notification
check all the requested configuration, all is correct. under Global, there is 'envelop' picture there.

 

Problem Clarification

policy server is unable to send email notification.

checked the startup.log, following part shows,
javax.mail.SendFailedException: Sending failed;
nested exception is:
javax.mail.MessagingException: Could not connect to SMTP host: avayamail.esl-asia.com, port: 25;
nested exception is:
java.net.ConnectException: Connection refused
at javax.mail.Transport.send0(Transport.java:219)
at javax.mail.Transport.send(Transport.java:81)
at com.axeda.common.notification.email.Emailer.send(Emailer.java:129)
at com.axeda.common.notification.email.Emailer.sendEmail(Emailer.java:62)
at com.axeda.apm.entity.notification.Notification.process(Notification.java:57)
at com.axeda.common.notification.NotificationManager.process(NotificationManager.java:100)
at com.axeda.common.notification.NotificationManager.run(NotificationManager.java:58)Ongoing issuetodayemail configuration changes

 

 

[root@IACAVAPOLICY policy]# wget  avayamail.esl-asia.com:25
--2017-07-12 12:01:24--  http://avayamail.esl-asia.com:25/
Resolving avayamail.esl-asia.com... 192.168.3.107
Connecting to avayamail.esl-asia.com|192.168.3.107|:25... failed: Connection refused.
[root@IACAVAPOLICY policy]#

Cause

port 25 to SMTP server is not open in customer's network.

Solution

customer opens the network port 25, email notification can be received.


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