SIP: Intermittently inbound or outbound calls fail, traces show CM sends a CANCEL after set of provisional responses from SIP provider


Doc ID    SOLN313321
Version:    2.0
Status:    Published
Published date:    20 Nov 2017
Created Date:    01 Aug 2017
Author:   
Charles Kuhn
 

Details

AVAYA Communication Manager 6.3, Session Manager 6.3.14, Oracle SBC, Airespring SIP carrier in UCaaS environment.
 

Problem Clarification

AVAYA Aura Communication Manager intermittently sending a CANCEL which doesn't allow the call setup to complete. On occasion the caller and callee will hear a quick ring, caller will get fast busy. The CANCEL from CM comes after the provisional responses (1XX responses) come back to CM from the direction of the SIP carrier. In many cases if only a 183 Session Progress with SDP was received from the direction of carrier then CM could complete the call (by not sending a cancel) but if only a set of 180 Ringing were the provisional responses then CM would send the CANCEL. 
 

 

Cause

Found that the SIP carrier on traffic destined back toward the SIP proxy (Session Manager) they were enabling 100Rel as a requirement which adds the Rseq value.

MST traces from CM showed that CM could not build a PRACK for each 180 Ring from SIP carrier direction due to an inability to parse each Rseq value. Without a PRACK for each 180 Ringing CM would send the CANCEL, failing the call setup.

Solution

Two solutions:

1. This is a CM defect, patch to be issued to resolve

2. If the SIP carrier can disable the 100 Rel requirement for traffic back in direction of ASM-CM then this will remove RSeq value that CM can't intermittently parse due to defect.

Attachment File


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