CallPilot: AOS service down on both servers


Doc ID    SOLN313463
Version:    1.0
Status:    Published
Published date:    23 Aug 2017
Author:   
John Lutter
 

Details

CallPilot 1006r:HA: AOS Service is down on both servers: NEED RCA.
Parent SR#1-13151312962
1 AUG 2017 07:51 PM GMT CHARLESC] RCA is as follows:
On 7/23 the system event log reported delayed network write errors to the network backup. Normally caused by a slow or restricted network. The backup did not complete successfully.
On 7/24 the IMA service and the EMC Autostart services stopped followed by the E & F drives losing sync (Event log states cracked)
The communication errors between the two systems did not show an issue with the network crossover cable between them (no legoto or network communication events.
On 7/29 the system was rebooted.
The CallPilot appeared to be coming up into service until the Telephony Service terminated unexpectedly followed by the AOS service doing the same thing.
Follow this the system would come up into service because the AOS service would terminate unexpectedly when it was attempted to start it.

Application logs for the 7/23 through 7/29 are were overwrote so we are missing that additional information.

With communication with the ER group the outage started with McAfee 8.8.
McAfee 8.8 is a supported version but in this case appears to of interrupted and corrupted the CallPilot software.

Problem Clarification

AOS service is down

Cause

Three possible sources:
1. McAfee 8.8 was not configured correctly per the documentation and interrupted the EMC autostart communication between the E and F drives.
2. McAfee 8.8 was not configured per the documentation and the it used up the system memory until it caused the communication error between the CallPilots.
3. McAfee 8.8 has added some updates that cause issues with the CallPilot.

Solution

Action: If the customer installs McAfee again Split RAID and install it on the offline side. Configure the software per the CallPilot AV doc and then fail over so AV can be put on the other CallPilot while its offline following the same steps.


Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy