Watchdog service restart on Session Manager


Doc ID    SOLN313785
Version:    2.0
Status:    Published
Published date:    26 Mar 2019
Created Date:    10 Aug 2017
Author:   
Sanjay Singh
 

Details

Session Manager 6.x, 7.x

[init@TXSIPINJXSM01 ~]$ swversion

Avaya Aura Session Manager Software Version Inventory

                   Release: 7.0.1.2.701230
           Call Processing: 7.0.1.2.701230
                Management: 7.0.1.2.701230
                  SM Tools: 7.0.1.2.701230
                       DRS: 7.0.1.2.701230
                       CDR: 7.0.1.2.701230
                       NCS: 7.65.16.01
           Security Module: 7.0.1.2.701201
                     nginx: 1.8.0
                  Firewall: 7.0.1.2.701201
              WebSphere AS: 8.5.5.4
                 SAL Agent: 7.0.1.0.6
                        OS: Red Hat Linux Release 6.5 (Santiago)
              VMware Tools: 9.4.11.42879 (build-2400950)
 

 

Problem Clarification

Watchdog Application is partially down.

Cause

Found Watchdog application partially down.

[root@TXSIPINJXSM01 run]# statapp
Watchdog          3/  9 PARTIALLY UP
logevent         35/ 35 UP
ncsd              4/  4 UP
postgres-db      32/ 32 UP
mgmt            319/319 UP
WebSphere       293/293 UP
CDRService       42/ 42 UP
cassandra       233/233 UP
sal-agent        59/ 59 UP
secmod            4/  4 UP

 

Solution

Restarted Watchdog service and issue got resolved.

1.Firstly we check if Watchdog Application is running.

We executed "service watchdsvc status" to check the status.

Status was running below is the output.

 watchd (pid 2469) is running...

2. Then we restarted the Watchdog application using "service watchdsvc restart" command.

Post restart we can see Watchdog application came up.

[root@TXSIPINJXSM01 run]# statapp
Watchdog          9/  9 UP
logevent         35/ 35 UP
ncsd              4/  4 UP
postgres-db      32/ 32 UP
mgmt            319/319 UP
WebSphere       293/293 UP
CDRService       42/ 42 UP
cassandra       232/232 UP
sal-agent        59/ 59 UP
secmod            4/  4 UP

 


Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy