SAL Gateway: SpiritAgent Will Start In Minimal Start Mode Only.


Doc ID    SOLN313875
Version:    6.0
Status:    Published
Published date:    20 Sep 2017
Created Date:    11 Aug 2017
Author:   
Mark Hunter
 

Details

SpiritAgent Minimal Start Mode only refers to SAL Gateway 3.0.

The SAL Gateway spiritAgent service in running in Minimal Start Mode only which indicates that there is an issue with either remote access or alarming.

Problem Clarification

The SAL Gateway spiritAgent starts in Minimal Start Mode only.

Cause

The Java installed on the SAL server does not have the correct permissions for the saluser account to read the Java. Or the incorrect version of Java is installed

Solution

If the Java version is incorrect; ensure that the Java installed is Java Runtime Enviroment (JRE) version 1.8. Uninstall the previous java instance

If the java version is correct, but the saluser account cannot read the java folder, follow the steps bellow:

Give 755 permissions to the Java directory by logging into the command line of the SAL server as root and navigate to where Java is installed and run the following command:

chmod 755 <Name of The Folder Containing The Java>

Java is usually installed in the /usr/Java directory but may be installed elsewhere.

Once completed, navigate to the Java directory and run the same command with the -R switch to the name of the Java folder to make sure that all files now have the same 755 permissions.

Do not restart the spiritAgent service remotely as this will break the remote connections and the spiritAgent may not come back up. Only restart the service while local to the SAL server.

Restart the spiritAgent service (service spiritAgent restart) to ensure that it is no longer running in Minimal Start Mode.

 

Additional Relevant Phrases

Sal 3.0 starts in minimal mode only

Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy