SAL 3.0 remote access unavailble after auto upgrade from 2.5


Doc ID    SOLN314009
Version:    2.0
Status:    Published
Published date:    19 Dec 2017
Created Date:    16 Aug 2017
Author:   
Lingxiao Wang
 

Details

Issues with access through SAL after gateway upgraded from  2.5 to 3.0
From Enterprise UI, the remote access button is in grey. and no last ping status.

Problem Clarification

SAL lost connection with Avaya after auto-upgrade from 2.5 to 3.0

Cause

1. from SAL web UI, all the health check has been passed, and test connectivity shows fine.
2. using wget command to test from CLI even returns with good results/
[root@mysal:/opt/avaya/SAL/gateway/SpiritAgent/logging ]
#: export https_proxy=https://cla-app-proxy.com:3128
[root@mysal:/opt/avaya/SAL/gateway/SpiritAgent/logging ]
#: wget --no-check-certificate https://remote.sal.avaya.com:443/eMessage
--2017-08-14 09:09:44-- https://remote.sal.avaya.com/eMessage
Resolving cla-app-proxy.com... 172.XX.XXX.XX
Connecting to cla-app-proxy.com|172.XX.XXX.XX|:3128... connected.
Proxy request sent, awaiting response... 200 OK
Length: 269 [application/octet]
Saving to: “eMessage”

100%[=========================================================================>] 269 --.-K/s in 0s

2017-08-14 09:09:47 (5.94 MB/s) - “eMessage” saved [269/269]

Solution

found below error in sal-ra-debug.log.

Aug 15 10:10:24.718 [EpollWorker-pool-12-thread-29] ERROR c.a.s.c.t.n.GenericNettyClientTransport - Error: Could not create channel from bootstrapper.
java.net.UnknownHostException: remote.sal.avaya.com
 
then add entry in /etc/hosts file. issue got resolved.

Additional Relevant Phrases

No active gateways available OR Remote access is disabled for the device.

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