multi-tenancy timezone not working.


Doc ID    SOLN317588
Version:    1.0
Status:    Published
Published date:    03 Nov 2017
Author:   
Ming Jiang
 

Details

multi-tenancy timezone not working.
R18Yesdefault time zone is working. second time zone for all time zone is also workingNo

Problem Clarification

tenant timezone though setup correctly, but still not working. supervisor can not display tenant time zone's data.

Cause

multi-tenancy feature not correctly installed

admin.log shows multi-tenancy feature being installed twice:
1st time:
CMS turned off Thu Mar 9 13:15:58 EST 2017
External call history package begin installation Thu Mar 9 13:16:10 EST 2017
Forecasting package begin installation Thu Mar 9 13:16:21 EST 2017
Forecasting package installed Thu Mar 9 13:16:22 EST 2017
Multi-tenancy package begin installation Thu Mar 9 13:16:32 EST 2017
Multi-tenancy package installed Thu Mar 9 13:16:32 EST 2017

2nd time:
uthorization command started Thu May 11 12:41:09 AEST 2017
Multi-tenancy automatically authorized.
Capabilities/capacities authorized Thu May 11 12:43:28 AEST 2017
Authorization command started Thu May 11 12:45:42 AEST 2017
Multi-tenancy automatically authorized.
Capabilities/capacities authorized Thu May 11 12:47:05 AEST 2017
Multi-tenancy package begin installation Fri Jun 16 21:03:54 AEST 2017
Multi-tenancy package installed Fri Jun 16 21:03:54 AEST 2017
Begin CMS DB Access Permissions changes: Thu Oct 19 13:27:47 AEST 2017
Finished. UNIX group dbaccess has no members. No changes to CMS DB.: Thu Oct 19

second time multi-tenancy feature installed is without cms turn off and turn on. thus it could not be in effect

We dig into database, find there is no tenancy record in database;

select * from dsplit where row_date="10/19/2017" and tenant=1 and i_stafftime!=0
0
select * from dvdn where row_date="10/19/2017" and tenant=1
0
select * from dsplit where tenant=1
0

Solution

follow the document to uninstall and reinstall the multi-tenancy feature, this require turning off and turn on cms.


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