AVAYA Virtualized Platform (AVP): Virtual Machines (VMs) hosted on AVP running SIP functions experiencing intermittent call failures and audio issues


Doc ID    SOLN318864
Version:    3.0
Status:    Published
Published date:    30 Nov 2017
Created Date:    30 Nov 2017
Author:   
Charles Kuhn
 

Details

Example: SIP Carrier Intellipeer to AVAYA SBC 7.2, Avaya Session Mgr 7.1 to Avaya CM 7.x

Problem Clarification

SIP traces showing frequent missing requests and responses from AVAYA SBCE internally to Session Manager (ASM), also saw missing responses from CM like missing 200 OKs. Initial look from the SIP VMs ASM nics showed speed of 10000 and Full duplex. The A1 interface of SBCE showed 100 Half duplex.

The B1 and M1 interfaces on SBCE showed correct speed and duplex

Cause

Customer confirmed that certain parts of their network are locked down to 100 Full. AVAYA SBCE nics are hard set to auto negotiate which when paired with a network switch set to auto negotiate will sync at half duplex.

For the ASM hosted on AVP and probably many other VMs like CM, AES, System Manager a check of the nic speeds and duplex might look clean. However, if an eth port is checked with ethtool for example from a VM it might show as 10000 Mbps and Full Duplex (most networks are not setup for 10000 Mbps, this might be a good sign to inquire if the VM is hosted on AVP or VMware).

How to check NIC speeds and duplexes from AVP:

1. Check from CLI of the AVP host by enabling SSH then running esxcfg-nics -l

~ # esxcfg-nics -l
Name    PCI           Driver      Link Speed     Duplex MAC Address       MTU    Description
vmnic0 0000:01:00.00 tg3         Up   100Mbps   Half   18:66:da:f9:4b:b4 1500   Broadcom Corporation NetXtreme BCM5720 Gigabit Ethernet
vmnic1 0000:01:00.01 tg3         Down 0Mbps     Full   18:66:da:f9:4b:b5 1500   Broadcom Corporation NetXtreme BCM5720 Gigabit Ethernet
vmnic2 0000:02:00.00 tg3         Down 0Mbps     Full   18:66:da:f9:4b:b6 1500   Broadcom Corporation NetXtreme BCM5720 Gigabit Ethernet
vmnic3 0000:02:00.01 tg3         Down 0Mbps     Full   18:66:da:f9:4b:b7 1500   Broadcom Corporation NetXtreme BCM5720 Gigabit Ethernet
vmnic4 0000:04:00.00 tg3         Down 0Mbps     Full   00:0a:f7:9d:e9:32 1500   Broadcom Corporation NetXtreme BCM5720 Gigabit Ethernet
vmnic5 0000:04:00.01 tg3         Down 0Mbps     Full   00:0a:f7:9d:e9:33 1500   Broadcom Corporation NetXtreme BCM5720 Gigabit Ethernet

2. Check from ESXI client or webUI

Solution

Best solution is to have customer set network switches to auto negotiation. Many AVAYA assets are hard coded to auto negotiate and while manual changes can be made to virtual NICs to disable auto and set a speed and duplex it is not recommended.

In most cases the network switch can be set to auto with immediate benefits and no increased disruptions to traffic integrity


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