CM: When enabling call forward to external destination CM takes only the first 3 digits of the number thus the destination is incorrect.


Doc ID    SOLN319595
Version:    2.0
Status:    Published
Published date:    29 Apr 2020
Created Date:    18 Dec 2017
Author:   
Levente Szabo
 

Details

CM:
vcm-017-01.0.532.0
patch: 01.0.532.0-23985

Equinox:
Equinox for Windows (3.2.2.2-ACW-DROP112; Microsoft Windows NT 6.2.9200.0)

SM:
AVAYA-SM-7.1.0.0.710028

Problem Clarification

Equinox Win user enabled call-forward-all to an external number eg: +491xxxxxxxxx. CM enables the CFWD for the first 3 digits of the destination number only and not considering the whole number, thus the destination number set for the CFWD is incorrect: 491.

Cause

Design and configuration issue.
Customer uses 3 digit long dial plan and has match on all numbers (1 through 9) with length: 3 as extension. When the CFWD is set to eg: +491xxxxxxxxx  CM matches on "4" and sets the destination as "491". The reason is that CM checks dial plan then UDP then AAR then ARS tables but as there is no exact match in any of these tables for "491xxxxxxxxx" ("+" character is not used for routing and customer does not want to use any steering numbers like ARS FAC when setting the CFWD destination) CM will eventually find the string in the dial plan, though with less numbers, but it will take it as best match. (Now it is also a coincidense that "491" does exist as an internal extension so this is a valid match.)


display dialplan analysis                                       Page   1 of  12
                             DIAL PLAN ANALYSIS TABLE
                                   Location: all            Percent Full: 4

    Dialed   Total  Call     Dialed   Total  Call     Dialed   Total  Call
    String   Length Type     String   Length Type     String   Length Type
   1           3   ext      9           3   ext
   2           3   ext      *0          4   fac
   3           3   ext      *1          4   fac
   4           3   ext      *2          4   fac
   5           3   ext      *3          4   fac
   6           3   ext      *8          4   dac
   7           3   ext      *9          2   dac
   8           3   ext     
 

Solution

configuration that works: adapt the dial plan to catch the CFWD destination numbers as type: UDP, define them also in UDP table and set type to AAR and send back to AAR table for ruting. Defining them as UDP type in dial plan made the trick to gather all the numbers not just the first 3 digits, and sending them back to AAR takes care of  the routing.
 

display dialplan analysis                                       Page   1 of  12
                             DIAL PLAN ANALYSIS TABLE
                                   Location: all            Percent Full: 4

    Dialed   Total  Call     Dialed   Total  Call     Dialed   Total  Call
    String   Length Type     String   Length Type     String   Length Type
   0           10  udp      9           3   ext
   00          11  udp      *0          4   fac
   00          12  udp      *1          4   fac
   00          13  udp      *2          4   fac
   00          14  udp      *3          4   fac
   00          15  udp      *8          4   dac
   00          16  udp      *9          2   dac
   1           3   ext
   2           3   ext
   3           3   ext
   4           3   ext
   5           3   ext
   6           3   ext
   7           3   ext
   8           3   ext

**********************

display uniform-dialplan 0                                      Page   1 of   2
                       UNIFORM DIAL PLAN TABLE
                                                              Percent Full: 0

  Matching                   Insert              Node
  Pattern       Len Del      Digits     Net Conv Num
 0               10  0                  aar  n
 00              10  0                  aar  n
 00              11  0                  aar  n
 00              12  0                  aar  n
 00              13  0                  aar  n
 00              14  0                  aar  n
 00              15  0                  aar  n
 00              16  0                  aar  n


*******************

display aar analysis 0                                          Page   1 of   2
                             AAR DIGIT ANALYSIS TABLE
                                   Location: all            Percent Full: 0

          Dialed           Total     Route    Call   Node  ANI
          String          Min  Max  Pattern   Type   Num   Reqd
    0                     1    20    2        aar          n
    00                    2    20    3        aar          n
    1                     3    3     1        aar          n
    2                     3    3     1        aar          n
    3                     3    3     1        aar          n
    4                     3    3     1        aar          n
    5                     3    3     1        aar          n
    6                     3    3     1        aar          n
    7                     3    3     1        aar          n
    8                     3    3     1        aar          n
    9                     3    3     1        aar          n


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