CM: SA8972 takes no effect even it's enabled and call forwarding is enabled


Doc ID    SOLN323240
Version:    2.0
Status:    Published
Published date:    11 Oct 2023
Created Date:    21 Mar 2018
Author:   
ghegyessy
 

Details

Communication Manager  6.x and 7.x releases
Avaya SIP phone 1120E
Call forwarding and SA8972 are enabled

Problem Clarification

When SA8972 and Call Forwarding are enabled, the caller identity is not changing as per SA8972.

SA8972 details:
 

Title : CM: SA8972 Overwrite calling party for Telecom Italia
Article ID : SOLN140418
Article Link : https://support.avaya.com/kb/ext/SOLN140418

 

Cause

Working as designed.

Local call forwarding was enabled on the phone set. In the SIP messaging this is clearly seen that the phone itself informs the caller about the call forwarding, however since SA8972 is a Communication Manager feature, it cannot be activated as CM is not aware of the call forwarding:

SIP/2.0 302 Moved Temporarily
(…)
From: <sip:[email protected]>;tag=73c61ecc215241e8811e050569eec2b
To: <sip:[email protected]>;tag=837810445
Call-ID: 73c61eea215241e8811f050569eec2b
CSeq: 1 INVITE
(…)

Based on the 1100 series documentation:

4.2.3. Call Forward Unconditional
It is recommended that this feature be administered as a Communication Manager FNE rather
than using the local call forward of the telephone. The user of local call forward will not benefit
from any of the call coverage features available in Communication Manager, including coverage
to voice messaging.”

 

Solution

Instead of using local call forwarding button on the phone, call forwarding of Communication Manager must be used by either using the FAC or a programmed call-fwd feature button.


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